summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-video/cheese/Manifest1
-rw-r--r--media-video/cheese/cheese-3.32.1.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/media-video/cheese/Manifest b/media-video/cheese/Manifest
index db9ce0dbb899..a5a487d4b914 100644
--- a/media-video/cheese/Manifest
+++ b/media-video/cheese/Manifest
@@ -1 +1,2 @@
DIST cheese-3.30.0.tar.xz 1546680 BLAKE2B 32cfc9553e1c9ebfe7d3eb5fdf19d74b49e9f69ea005f4c79097d69caa2125803c5c319e98ccd3e8f72157a5fd86c018f1be7af7045f6541ecd36d4162c5cdd1 SHA512 622910cedc8eadec4161f60e2bb3f02cbe11352b2431fdd9783f724b4119ffae6254b1566e1144c25491067f9c683a55eb85b265ef28992d852adce02fbdc8b4
+DIST cheese-3.32.1.tar.xz 1487792 BLAKE2B 6e27b68f590aa4f90a8bbbc72972bed96fe9741b4efd849d226751cfd6abe37241fa214240c4a8b0449fb2bc53de1043ac0abd60a06bc884796a4272c07212af SHA512 bdd0ae72e3df596d19ad467dc0222a49b028f2ad8c285d55360813624ca2dac1956463cfd9cea4f2a6ff123070966544cd7254ee2891e973dca42d07061a6c94
diff --git a/media-video/cheese/cheese-3.32.1.ebuild b/media-video/cheese/cheese-3.32.1.ebuild
new file mode 100644
index 000000000000..9107e56ee5a7
--- /dev/null
+++ b/media-video/cheese/cheese-3.32.1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2 virtualx
+
+DESCRIPTION="A cheesy program to take pictures and videos from your webcam"
+HOMEPAGE="https://wiki.gnome.org/Apps/Cheese"
+
+LICENSE="GPL-2+"
+SLOT="0/8" # subslot = libcheese soname version
+IUSE="+introspection"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.39.90:2
+ >=x11-libs/gtk+-3.13.4:3[introspection?]
+ >=gnome-base/gnome-desktop-2.91.6:3=
+ >=media-libs/libcanberra-0.26[gtk3]
+ >=media-libs/clutter-1.13.2:1.0[introspection?]
+ >=media-libs/clutter-gtk-0.91.8:1.0
+ media-libs/clutter-gst:3.0
+ media-libs/cogl:1.0=[introspection?]
+
+ media-video/gnome-video-effects
+ x11-libs/gdk-pixbuf:2[jpeg,introspection?]
+ x11-libs/libX11
+ x11-libs/libXtst
+
+ >=media-libs/gstreamer-1.4:1.0[introspection?]
+ >=media-libs/gst-plugins-base-1.4:1.0[introspection?,ogg,pango,theora,vorbis,X]
+
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7:= )
+"
+RDEPEND="${COMMON_DEPEND}
+ >=media-libs/gst-plugins-bad-1.4:1.0
+ >=media-libs/gst-plugins-good-1.4:1.0
+
+ >=media-plugins/gst-plugins-jpeg-1.4:1.0
+ >=media-plugins/gst-plugins-v4l2-1.4:1.0
+ >=media-plugins/gst-plugins-vpx-1.4:1.0
+"
+# libxml2+gdk-pixbuf required for glib-compile-resources
+DEPEND="${COMMON_DEPEND}
+ app-text/docbook-xml-dtd:4.3
+ dev-libs/appstream-glib
+ dev-libs/libxml2:2
+ dev-libs/libxslt
+ dev-util/glib-utils
+ >=dev-util/gtk-doc-am-1.14
+ >=dev-util/intltool-0.50
+ dev-util/itstool
+ virtual/pkgconfig
+ x11-base/xorg-proto
+"
+# eautoreconf needs yelp-tools
+
+src_configure() {
+ gnome2_src_configure \
+ GST_INSPECT=$(type -P true) \
+ GTESTER_REPORT=$(type -P true) \
+ VALAC=$(type -P true) \
+ $(use_enable introspection) \
+ --disable-lcov \
+ --disable-static
+}
+
+src_test() {
+ "${EROOT}${GLIB_COMPILE_SCHEMAS}" --allow-any-name "${S}/data" || die
+ GSETTINGS_SCHEMA_DIR="${S}/data" virtx emake check
+}