summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-wireless/blueman/blueman-2.1.1.ebuild7
-rw-r--r--net-wireless/blueman/blueman-9999.ebuild7
2 files changed, 8 insertions, 6 deletions
diff --git a/net-wireless/blueman/blueman-2.1.1.ebuild b/net-wireless/blueman/blueman-2.1.1.ebuild
index 6f86023ac9c9..afa7dd91ce10 100644
--- a/net-wireless/blueman/blueman-2.1.1.ebuild
+++ b/net-wireless/blueman/blueman-2.1.1.ebuild
@@ -4,13 +4,13 @@
EAPI="7"
PYTHON_COMPAT=( python3_{5,6,7} )
-inherit gnome2-utils linux-info python-single-r1 systemd xdg-utils
+inherit autotools gnome2-utils linux-info python-single-r1 systemd xdg-utils
DESCRIPTION="Simple and intuitive GTK+ Bluetooth Manager"
HOMEPAGE="https://github.com/blueman-project/blueman"
if [[ ${PV} == "9999" ]] ; then
- inherit autotools git-r3
+ inherit git-r3
EGIT_REPO_URI="https://github.com/blueman-project/blueman.git"
KEYWORDS=""
else
@@ -78,7 +78,8 @@ pkg_setup() {
src_prepare() {
default
- [[ ${PV} == 9999 ]] && eautoreconf
+ # replace py-compile to fix py3
+ [[ ${PV} == 9999 ]] && eautoreconf || eautomake
}
src_configure() {
diff --git a/net-wireless/blueman/blueman-9999.ebuild b/net-wireless/blueman/blueman-9999.ebuild
index 685f3219bdb6..4e3c0edd40da 100644
--- a/net-wireless/blueman/blueman-9999.ebuild
+++ b/net-wireless/blueman/blueman-9999.ebuild
@@ -4,13 +4,13 @@
EAPI="7"
PYTHON_COMPAT=( python3_{5,6,7} )
-inherit gnome2-utils linux-info python-single-r1 systemd xdg-utils
+inherit autotools gnome2-utils linux-info python-single-r1 systemd xdg-utils
DESCRIPTION="Simple and intuitive GTK+ Bluetooth Manager"
HOMEPAGE="https://github.com/blueman-project/blueman"
if [[ ${PV} == "9999" ]] ; then
- inherit autotools git-r3
+ inherit git-r3
EGIT_REPO_URI="https://github.com/blueman-project/blueman.git"
KEYWORDS=""
else
@@ -76,7 +76,8 @@ pkg_setup() {
src_prepare() {
default
- [[ ${PV} == 9999 ]] && eautoreconf
+ # replace py-compile to fix py3
+ [[ ${PV} == 9999 ]] && eautoreconf || eautomake
}
src_configure() {