summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/cryptography/cryptography-2.6.1-r1.ebuild (renamed from dev-python/cryptography/cryptography-2.6.1.ebuild)4
-rw-r--r--dev-python/cryptography/cryptography-2.8-r1.ebuild (renamed from dev-python/cryptography/cryptography-2.8.ebuild)4
2 files changed, 4 insertions, 4 deletions
diff --git a/dev-python/cryptography/cryptography-2.6.1.ebuild b/dev-python/cryptography/cryptography-2.6.1-r1.ebuild
index 5eb0f608b495..d0c85a6a8fd1 100644
--- a/dev-python/cryptography/cryptography-2.6.1.ebuild
+++ b/dev-python/cryptography/cryptography-2.6.1-r1.ebuild
@@ -39,11 +39,11 @@ RDEPEND="
>=dev-python/six-1.4.1[${PYTHON_USEDEP}]
virtual/python-enum34[${PYTHON_USEDEP}]
virtual/python-ipaddress[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/cffi-1.8:=[${PYTHON_USEDEP}]' 'python*')
+ $(python_gen_cond_dep '!~dev-python/cffi-1.11.3[${PYTHON_USEDEP}]' 'python*')
"
DEPEND="${RDEPEND}
>=dev-python/setuptools-1.0[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '>=dev-python/cffi-1.8:=[${PYTHON_USEDEP}]' 'python*')
- $(python_gen_cond_dep '!~dev-python/cffi-1.11.3[${PYTHON_USEDEP}]' 'python*')
test? (
~dev-python/cryptography-vectors-${PV}[${PYTHON_USEDEP}]
dev-python/pretend[${PYTHON_USEDEP}]
diff --git a/dev-python/cryptography/cryptography-2.8.ebuild b/dev-python/cryptography/cryptography-2.8-r1.ebuild
index edd5696da250..a3a34f92d7fc 100644
--- a/dev-python/cryptography/cryptography-2.8.ebuild
+++ b/dev-python/cryptography/cryptography-2.8-r1.ebuild
@@ -40,11 +40,11 @@ RDEPEND="
>=dev-python/six-1.4.1[${PYTHON_USEDEP}]
virtual/python-enum34[${PYTHON_USEDEP}]
virtual/python-ipaddress[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/cffi-1.8:=[${PYTHON_USEDEP}]' 'python*')
+ $(python_gen_cond_dep '!~dev-python/cffi-1.11.3[${PYTHON_USEDEP}]' 'python*')
"
DEPEND="${RDEPEND}
>=dev-python/setuptools-1.0[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '>=dev-python/cffi-1.8:=[${PYTHON_USEDEP}]' 'python*')
- $(python_gen_cond_dep '!~dev-python/cffi-1.11.3[${PYTHON_USEDEP}]' 'python*')
test? (
dev-python/pretend[${PYTHON_USEDEP}]
dev-python/iso8601[${PYTHON_USEDEP}]