summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-shells/rush/Manifest1
-rw-r--r--app-shells/rush/metadata.xml8
-rw-r--r--app-shells/rush/rush-2.0.ebuild25
3 files changed, 34 insertions, 0 deletions
diff --git a/app-shells/rush/Manifest b/app-shells/rush/Manifest
new file mode 100644
index 000000000000..484d5b66d7f5
--- /dev/null
+++ b/app-shells/rush/Manifest
@@ -0,0 +1 @@
+DIST rush-2.0.tar.xz 810096 BLAKE2B 793f341910cfa5e1560928ea96234ebcd5185e00450c81fd03e67598227973248ebe2dd12fecaba135fcf991d830e44d2e8b273ff251d1f9b8038df2575ae3cd SHA512 7087962d0489e2cdac903abf193e7b1306ae8f76eae7f722f105a70a14aae3d72627de230edd104da34ea31aa07cdc8024eff33a9c70b987a2111435fe2a684e
diff --git a/app-shells/rush/metadata.xml b/app-shells/rush/metadata.xml
new file mode 100644
index 000000000000..c7be278b6458
--- /dev/null
+++ b/app-shells/rush/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>polynomial-c@gentoo.org</email>
+ <name>Lars Wendler</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-shells/rush/rush-2.0.ebuild b/app-shells/rush/rush-2.0.ebuild
new file mode 100644
index 000000000000..7aa729941079
--- /dev/null
+++ b/app-shells/rush/rush-2.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Restricted User Shell"
+HOMEPAGE="https://puszcza.gnu.org.ua/projects/rush/"
+SRC_URI="ftp://download.gnu.org.ua/pub/release/${PN}/${P}.tar.xz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-3"
+SLOT="0"
+
+IUSE="nls"
+
+BDEPEND="
+ nls? ( sys-devel/gettext )
+"
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable nls)
+ )
+ econf "${myeconfargs[@]}"
+}