summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-libs/signon-oauth2/Manifest1
-rw-r--r--net-libs/signon-oauth2/files/signon-oauth2-0.24-disable-examples.patch14
-rw-r--r--net-libs/signon-oauth2/files/signon-oauth2-0.24-dont-install-tests.patch11
-rw-r--r--net-libs/signon-oauth2/signon-oauth2-0.24.ebuild50
4 files changed, 76 insertions, 0 deletions
diff --git a/net-libs/signon-oauth2/Manifest b/net-libs/signon-oauth2/Manifest
index b3c3b8027648..57126546b876 100644
--- a/net-libs/signon-oauth2/Manifest
+++ b/net-libs/signon-oauth2/Manifest
@@ -1 +1,2 @@
DIST signon-oauth2-0.21.tar.bz2 37819 BLAKE2B 5de9add1952ba94e12b776c7f4b462bfc31ce01c148d8819b6e159510c4b00f4d2fc915a62f585b1061d46efbeb92406e3c117452e4e7f5575404fea3ab20601 SHA512 b0f97353e87c08420c3132f3357522b526a7c48df807ab833e05297ebfc86e0e8f25d4d3aa94e8ebc4aa1d9bc77856d63c43e5b5e9f3e63628f7710b9a056fd0
+DIST signon-oauth2-0.24.tar.gz 39011 BLAKE2B 41b672d1f489321b2f93f245530da1e51867eb4f0d1675ba72240f59f5ab7d6d2a079899e1a6dbc63c82bc53e1fab467c6696f5171c98ab00243d5ec9ddd92f4 SHA512 8a1e5be7f34419ded7841cb4de62e03ab56556f39ae40e3e11b549d45c6c51edc6888d1aab254c0ba6746d6306bb8b92dd24e473387542d6a987208c20acf6d9
diff --git a/net-libs/signon-oauth2/files/signon-oauth2-0.24-disable-examples.patch b/net-libs/signon-oauth2/files/signon-oauth2-0.24-disable-examples.patch
new file mode 100644
index 000000000000..dd730e449773
--- /dev/null
+++ b/net-libs/signon-oauth2/files/signon-oauth2-0.24-disable-examples.patch
@@ -0,0 +1,14 @@
+Author: Diane Trout <diane@ghic.org>
+Description: Don't install the examples as they end up conflicting with
+ other packages.
+--- a/signon-oauth2.pro
++++ b/signon-oauth2.pro
+@@ -3,7 +3,7 @@
+
+ TEMPLATE = subdirs
+ CONFIG += ordered
+-SUBDIRS = src tests example
++SUBDIRS = src tests
+
+ include( common-installs-config.pri )
+
diff --git a/net-libs/signon-oauth2/files/signon-oauth2-0.24-dont-install-tests.patch b/net-libs/signon-oauth2/files/signon-oauth2-0.24-dont-install-tests.patch
new file mode 100644
index 000000000000..615bc8b562d2
--- /dev/null
+++ b/net-libs/signon-oauth2/files/signon-oauth2-0.24-dont-install-tests.patch
@@ -0,0 +1,11 @@
+--- a/tests/tests.pro 2018-05-29 22:51:43.766914590 +0200
++++ b/tests/tests.pro 2018-05-29 22:52:45.247259336 +0200
+@@ -32,8 +32,6 @@
+ target.path = $${INSTALL_PREFIX}/bin
+ testsuite.path = $${INSTALL_PREFIX}/share/$$TARGET
+ testsuite.files = tests.xml
+-INSTALLS += target \
+- testsuite
+
+ check.depends = $$TARGET
+ check.commands = ./$$TARGET || :
diff --git a/net-libs/signon-oauth2/signon-oauth2-0.24.ebuild b/net-libs/signon-oauth2/signon-oauth2-0.24.ebuild
new file mode 100644
index 000000000000..ea3dd0c41f71
--- /dev/null
+++ b/net-libs/signon-oauth2/signon-oauth2-0.24.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN=signon-plugin-oauth2
+MY_PV=VERSION_${PV}
+inherit qmake-utils
+
+DESCRIPTION="OAuth2 plugin for Signon daemon"
+HOMEPAGE="https://01.org/gsso/"
+SRC_URI="https://gitlab.com/accounts-sso/${MY_PN}/-/archive/${MY_PV}/${MY_PN}-${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtnetwork:5[ssl]
+ net-libs/signond
+"
+DEPEND="${RDEPEND}
+ test? ( dev-qt/qttest:5 )
+"
+
+S="${WORKDIR}/${MY_PN}-${MY_PV}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-disable-examples.patch"
+ "${FILESDIR}/${P}-dont-install-tests.patch"
+)
+
+src_prepare() {
+ default
+
+ if ! use test; then
+ sed -i -e '/^SUBDIRS/s/tests//' signon-oauth2.pro || die "Failed to disable tests"
+ fi
+}
+
+src_configure() {
+ eqmake5 \
+ LIBDIR=/usr/$(get_libdir)
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+}