summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-biology/bamtools/bamtools-2.5.1.ebuild6
-rw-r--r--sci-biology/bamtools/bamtools-9999.ebuild6
-rw-r--r--sci-libs/dcmtk/dcmtk-3.6.5.ebuild11
-rw-r--r--sci-libs/symengine/symengine-0.5.0.ebuild8
4 files changed, 15 insertions, 16 deletions
diff --git a/sci-biology/bamtools/bamtools-2.5.1.ebuild b/sci-biology/bamtools/bamtools-2.5.1.ebuild
index b5affe9f0fa9..78a0c3cd2553 100644
--- a/sci-biology/bamtools/bamtools-2.5.1.ebuild
+++ b/sci-biology/bamtools/bamtools-2.5.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake-utils
+inherit cmake
DESCRIPTION="A programmer's API and an end-user's toolkit for handling BAM files"
HOMEPAGE="https://github.com/pezmaster31/bamtools"
@@ -29,5 +29,5 @@ src_prepare() {
# delete bundled libs, just to be safe
rm -rf src/third_party/{gtest-1.6.0,jsoncpp} || die
- cmake-utils_src_prepare
+ cmake_src_prepare
}
diff --git a/sci-biology/bamtools/bamtools-9999.ebuild b/sci-biology/bamtools/bamtools-9999.ebuild
index b5affe9f0fa9..78a0c3cd2553 100644
--- a/sci-biology/bamtools/bamtools-9999.ebuild
+++ b/sci-biology/bamtools/bamtools-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake-utils
+inherit cmake
DESCRIPTION="A programmer's API and an end-user's toolkit for handling BAM files"
HOMEPAGE="https://github.com/pezmaster31/bamtools"
@@ -29,5 +29,5 @@ src_prepare() {
# delete bundled libs, just to be safe
rm -rf src/third_party/{gtest-1.6.0,jsoncpp} || die
- cmake-utils_src_prepare
+ cmake_src_prepare
}
diff --git a/sci-libs/dcmtk/dcmtk-3.6.5.ebuild b/sci-libs/dcmtk/dcmtk-3.6.5.ebuild
index 62dcaa4d598b..240ca02f96fb 100644
--- a/sci-libs/dcmtk/dcmtk-3.6.5.ebuild
+++ b/sci-libs/dcmtk/dcmtk-3.6.5.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils
+inherit cmake
DESCRIPTION="The DICOM Toolkit"
HOMEPAGE="https://dicom.offis.de/dcmtk.php.en"
@@ -30,7 +30,7 @@ DEPEND="${RDEPEND}
BDEPEND="doc? ( app-doc/doxygen )"
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
sed -e "s:share/doc/dcmtk:&-${PV}:" \
-e "s:DIR \"/:DIR \"/usr/:" \
@@ -51,7 +51,6 @@ src_prepare() {
src_configure() {
local mycmakeargs=(
- -DBUILD_SHARED_LIBS=ON
-DCMAKE_INSTALL_SYSCONFDIR="${EROOT}/etc"
-DDCMTK_WITH_ICU=ON
-DDCMTK_WITH_TIFF=$(usex tiff)
@@ -63,7 +62,7 @@ src_configure() {
-DDCMTK_WITH_THREADS=$(usex threads)
)
- cmake-utils_src_configure
+ cmake_src_configure
if use doc; then
cd "${S}"/doxygen || die
@@ -72,7 +71,7 @@ src_configure() {
}
src_compile() {
- cmake-utils_src_compile
+ cmake_src_compile
if use doc; then
emake -C "${S}"/doxygen
@@ -85,5 +84,5 @@ src_install() {
if use doc; then
local HTML_DOCS=( "${S}"/doxygen/htmldocs/. )
fi
- cmake-utils_src_install
+ cmake_src_install
}
diff --git a/sci-libs/symengine/symengine-0.5.0.ebuild b/sci-libs/symengine/symengine-0.5.0.ebuild
index 725e60e3d7f9..6b84f4677d6c 100644
--- a/sci-libs/symengine/symengine-0.5.0.ebuild
+++ b/sci-libs/symengine/symengine-0.5.0.ebuild
@@ -3,7 +3,8 @@
EAPI=7
-inherit cmake-utils flag-o-matic
+CMAKE_BUILD_TYPE=Release
+inherit cmake flag-o-matic
DESCRIPTION="Fast symbolic manipulation library, written in C++"
HOMEPAGE="https://github.com/sympy/symengine"
@@ -33,7 +34,7 @@ pkg_pretend() {
}
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
sed -e "s|DESTINATION doc| DESTINATION share/doc/${PF}/html|" \
-e "s|/lib|/$(get_libdir)|g" \
-e "s|lib/|$(get_libdir)/|g" \
@@ -57,7 +58,6 @@ src_configure() {
local mycmakeargs=(
-DARB_INCLUDE_DIR="${EPREFIX}/usr/include"
-DINTEGER_CLASS="${int_class}"
- -DBUILD_SHARED_LIBS=ON
-DBUILD_BENCHMARKS="$(usex benchmarks)"
-DBUILD_DOXYGEN="$(usex doc)"
-DBUILD_TESTS="$(usex test)"
@@ -75,5 +75,5 @@ src_configure() {
-DWITH_ECM="$(usex ecm)"
)
test-flag-CXX -std=c++11 && append-cxxflags -std=c++11
- CMAKE_BUILD_TYPE=Release cmake-utils_src_configure
+ cmake_src_configure
}