summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-mathematics/gmm/gmm-5.1.ebuild9
1 files changed, 9 insertions, 0 deletions
diff --git a/sci-mathematics/gmm/gmm-5.1.ebuild b/sci-mathematics/gmm/gmm-5.1.ebuild
index f815c7743301..3165e306952b 100644
--- a/sci-mathematics/gmm/gmm-5.1.ebuild
+++ b/sci-mathematics/gmm/gmm-5.1.ebuild
@@ -3,6 +3,8 @@
EAPI=6
+inherit flag-o-matic
+
DESCRIPTION="Generic C++ template library for sparse, dense and skyline matrices"
SRC_URI="http://download.gna.org/getfem/stable/${P}.tar.gz"
HOMEPAGE="http://www-gmm.insa-toulouse.fr/getfem/"
@@ -11,3 +13,10 @@ LICENSE="|| ( LGPL-3 LGPL-3-with-linking-exception )"
SLOT="0"
KEYWORDS="amd64 ~arm ~hppa ~ppc ~ppc64 x86 ~x86-fbsd ~amd64-linux ~x86-linux"
IUSE=""
+
+src_configure() {
+ # required for tests, #612294
+ append-cxxflags -std=c++14
+
+ default
+}