summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/pathlib2/Manifest1
-rw-r--r--dev-python/pathlib2/pathlib2-2.3.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/pathlib2/Manifest b/dev-python/pathlib2/Manifest
index d31e4132fdea..9e7baa603dc9 100644
--- a/dev-python/pathlib2/Manifest
+++ b/dev-python/pathlib2/Manifest
@@ -1 +1,2 @@
DIST pathlib2-2.1.0.tar.gz 30390 SHA256 deb3a960c1d55868dfbcac98432358b92ba89d95029cddd4040db1f27405055c SHA512 5dad54d4bf7a37a2c425afeca030a23d802a8a450186292f3d80aa9ee5c2985701871a0386a2f58e2b05b4bbfd7734a238d0a73625c5839237e4f3984088a8b1 WHIRLPOOL 61507dca96da2ed128fd3f8c0f5afe2c993dc56da3de294db7600aa38016a97891be2e9aede2f067cd52040939bc14ed139553004d4c98df72d32a3516719c73
+DIST pathlib2-2.3.0.tar.gz 34291 SHA256 d32550b75a818b289bd4c1f96b60c89957811da205afcceab75bc8b4857ea5b3 SHA512 715fbd981d42767862dcaf2cc0fee31b9ec5050915ef7d909d14587609a7a5939e32b39736b586a890e7625443bb163832896fcf138b5c2863c451b71c36a124 WHIRLPOOL d8f1ebbf66aecc274b9567280666709595ecff9efcaeafb718b6990fc6f8185c42656ec1aa97d32168d78a207f5a9edcd527f6b25184b96b9b246a9ffcd3fb26
diff --git a/dev-python/pathlib2/pathlib2-2.3.0.ebuild b/dev-python/pathlib2/pathlib2-2.3.0.ebuild
new file mode 100644
index 000000000000..e4c21c8d96a9
--- /dev/null
+++ b/dev-python/pathlib2/pathlib2-2.3.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Fork of pathlib aiming to support the full stdlib Python API"
+HOMEPAGE="https://github.com/mcmtroffaes/pathlib2"
+SRC_URI="mirror://pypi/p/pathlib2/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ $(python_gen_cond_dep 'dev-python/scandir[${PYTHON_USEDEP}]' 'python2*' python3_4 pypy )
+ dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ "${EPYTHON}" test_pathlib2.py || die
+}