summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/pywinrm/Manifest1
-rw-r--r--dev-python/pywinrm/pywinrm-0.4.1.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/pywinrm/Manifest b/dev-python/pywinrm/Manifest
index 1e48e5e6d51b..da8b690114e3 100644
--- a/dev-python/pywinrm/Manifest
+++ b/dev-python/pywinrm/Manifest
@@ -1 +1,2 @@
DIST pywinrm-0.3.0.tar.gz 25175 BLAKE2B bf020a2343dd317234d52600425930c9e8a798d07443f33279950d011c23ecffef97eb10042f4453ca8062d163c75c694d04b1e1f9facc3a6fe1da8d6840671d SHA512 4a6ec3e5cc4b9030275454d846fa4356f444481fe798f013f2be4dbfd4974f11ab2ccaabbc749f6e64fda985324ce6ffb1af906cdca02d2e2cb606d10bb94d02
+DIST pywinrm-0.4.1.tar.gz 36391 BLAKE2B 13b4db5292648fb497a4b85f6051ea2ea880ec9c1bd5970673e983b217c0787ccd0e1e504c8af12b0c4941294a440ef0449f968ba446254558a10df69bbcccdf SHA512 0eaeb190d37f055c10d1bd8ae1414da4a7396351fd6286b1e5ffc22b8f8ed589c03e2cbf1c287e5ea8fc00c08012a206657cecb77ec69cd373ff462c3b18e3d7
diff --git a/dev-python/pywinrm/pywinrm-0.4.1.ebuild b/dev-python/pywinrm/pywinrm-0.4.1.ebuild
new file mode 100644
index 000000000000..59c86e78eead
--- /dev/null
+++ b/dev-python/pywinrm/pywinrm-0.4.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+inherit distutils-r1
+
+DESCRIPTION="Windows Remote Management through Python"
+HOMEPAGE="https://pypi.org/project/pywinrm/"
+SRC_URI="mirror://pypi/p/pywinrm/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-python/xmltodict[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/requests-credssp[${PYTHON_USEDEP}]
+ dev-python/requests-kerberos[${PYTHON_USEDEP}]
+ dev-python/requests-ntlm[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"