summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-analyzer/ike-scan/Manifest1
-rw-r--r--net-analyzer/ike-scan/files/ike-scan-1.9.5-clang-16.patch92
-rw-r--r--net-analyzer/ike-scan/ike-scan-1.9.5.ebuild (renamed from net-analyzer/ike-scan/ike-scan-99999.ebuild)31
-rw-r--r--net-analyzer/nfdump/Manifest2
-rw-r--r--net-analyzer/nfdump/files/nfdump-1.6.19-compiler.patch21
-rw-r--r--net-analyzer/nfdump/files/nfdump-1.6.23-autotools.patch216
-rw-r--r--net-analyzer/nfdump/files/nfdump-1.6.23-m4-dir-automake.patch23
-rw-r--r--net-analyzer/nfdump/files/nfdump-1.6.23-m4-dir.patch19
-rw-r--r--net-analyzer/nfdump/nfdump-1.6.23.ebuild82
-rw-r--r--net-analyzer/nfdump/nfdump-1.7.0.1.ebuild (renamed from net-analyzer/nfdump/nfdump-1.6.23-r1.ebuild)8
-rw-r--r--net-analyzer/sniffit/files/sniffit-0.5.0-implicit-func-decl.patch50
-rw-r--r--net-analyzer/sniffit/sniffit-0.5-r1.ebuild (renamed from net-analyzer/sniffit/sniffit-0.5.ebuild)16
12 files changed, 173 insertions, 388 deletions
diff --git a/net-analyzer/ike-scan/Manifest b/net-analyzer/ike-scan/Manifest
index e0cdada21dde..adfb9c5d9279 100644
--- a/net-analyzer/ike-scan/Manifest
+++ b/net-analyzer/ike-scan/Manifest
@@ -1 +1,2 @@
DIST ike-scan-1.9.4.tar.gz 1360202 BLAKE2B abe206b22a23a6d4eaa2218204657d6c47f22ac8009df1f1e7918fbb55575033f237462ed57ba89aee8bed28e47a4dacf69e443dac5cd3b506842e26e71f97e9 SHA512 d7dde6d3d76a2e3ddeb9ed1f0dee3e2c3a13d4afa57ebb8ff19f6af094f7334b464509cee6ffc385d2703bcf9bc1c503bc604506279518f692f82c8f12f146be
+DIST ike-scan-1.9.5.tar.gz 1542264 BLAKE2B 3095c2929c7f24da43852402a3e5cfe73dd65100773283ef08b791784be2e2f04bba24843469e407695a027e76e1e0aa18effabc210643414677a35df7f2614c SHA512 5eb98e41c639bc30996041f4e759a6ada7f4baa5b8102992ac2313ed8ff51032d877b116bc24972e0ecd652290849aa67a63523d92ee63af6577112350ee5590
diff --git a/net-analyzer/ike-scan/files/ike-scan-1.9.5-clang-16.patch b/net-analyzer/ike-scan/files/ike-scan-1.9.5-clang-16.patch
new file mode 100644
index 000000000000..c4aec2836ba0
--- /dev/null
+++ b/net-analyzer/ike-scan/files/ike-scan-1.9.5-clang-16.patch
@@ -0,0 +1,92 @@
+https://github.com/royhills/ike-scan/pull/39
+
+From 9949ce4bdf9f4bcb616b2a5d273708a7ea9ee93d Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Mon, 26 Sep 2022 05:22:18 +0100
+Subject: [PATCH 1/3] acinclude.m4: fix -Wimplicit-int errors (Clang 16+
+ compat)
+
+--- a/acinclude.m4
++++ b/acinclude.m4
+@@ -144,7 +144,7 @@ int does_int64_work()
+ return 0;
+ return 1;
+ }
+-main() {
++int main() {
+ return ! does_int64_work();
+ }],
+ [Ac_cachevar=yes],
+@@ -200,7 +200,7 @@ int does_int64_snprintf_work()
+ return 0; /* either multiply or snprintf is busted */
+ return 1;
+ }
+-main() {
++int main() {
+ return ! does_int64_snprintf_work();
+ }],
+ [pgac_cv_snprintf_long_long_int_format=$pgac_format; break],
+
+From 6a931ca559a937cb9f7917b9131ec1aca4919683 Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Mon, 26 Sep 2022 05:23:06 +0100
+Subject: [PATCH 2/3] acinclude.m4: fix typo in 'x' if check
+
+Case doesn't matter but case does need to match on left & right
+hand side, so just choose uppercase everywhere to match what
+the rest of the file does.
+--- a/acinclude.m4
++++ b/acinclude.m4
+@@ -278,7 +278,7 @@ dnl in <features.h>. We don't use __GNUC_PREREQ directly because <features.h>
+ dnl is not present on all the operating systems that we support, e.g. OpenBSD.
+ dnl
+ AC_DEFUN([GCC_FORTIFY_SOURCE],[
+- if test "x$CC" != "X"; then
++ if test "X$CC" != "X"; then
+ AC_MSG_CHECKING([whether ${CC} accepts -D_FORTIFY_SOURCE])
+ AC_TRY_COMPILE(,[
+ #define GNUC_PREREQ(maj, min) ((__GNUC__ << 16) + __GNUC_MINOR__ >= ((maj) << 16) + (min))
+@@ -311,7 +311,7 @@ dnl If it is not supported, then the test program will compile without
+ dnl warnings.
+ dnl
+ AC_DEFUN([GCC_FORMAT_SECURITY],[
+- if test "x$CC" != "X"; then
++ if test "X$CC" != "X"; then
+ AC_MSG_CHECKING([whether ${CC} accepts -Wformat-security])
+ wfs_old_cflags="$CFLAGS"
+ CFLAGS="$CFLAGS -Wall -Werror -Wformat -Wformat-security"
+
+From fbc40c7b117b523eceb9aa58d6086bde701f1299 Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Sat, 1 Oct 2022 01:24:04 +0100
+Subject: [PATCH 3/3] configure.ac: Fix recognising -Wformat-security with
+ Clang
+
+Before:
+```
+checking whether clang accepts -fstack-protector... yes
+checking whether clang accepts -D_FORTIFY_SOURCE... yes
+checking whether clang accepts -Wformat-security... no
+```
+
+After:
+```
+checking whether clang accepts -fstack-protector... yes
+checking whether clang accepts -Wformat-security... yes
+checking whether clang accepts -D_FORTIFY_SOURCE... yes
+```
+
+Signed-off-by: Sam James <sam@gentoo.org>
+--- a/configure.ac
++++ b/configure.ac
+@@ -34,8 +34,8 @@ if test -n "$GCC"; then
+ CFLAGS="$CFLAGS -Wall -Wshadow -Wwrite-strings"
+ GCC_WEXTRA
+ GCC_STACK_PROTECT_CC
+- GCC_FORTIFY_SOURCE
+ GCC_FORMAT_SECURITY
++ GCC_FORTIFY_SOURCE
+ dnl Uncomment the lines below for testing with stricter warnings.
+ dnl CFLAGS="$CFLAGS -pedantic -Wpointer-arith -Wcast-qual -Wcast-align -Wconversion -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -Winline "
+ dnl Uncomment the line below to check malloc/free with electric fence
+
diff --git a/net-analyzer/ike-scan/ike-scan-99999.ebuild b/net-analyzer/ike-scan/ike-scan-1.9.5.ebuild
index 4e89ede7807a..acfffd464bb0 100644
--- a/net-analyzer/ike-scan/ike-scan-99999.ebuild
+++ b/net-analyzer/ike-scan/ike-scan-1.9.5.ebuild
@@ -1,35 +1,34 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-inherit autotools git-r3
+EAPI=8
+
+inherit autotools
DESCRIPTION="A utility for finding, fingerprinting and testing IKE VPN servers"
-HOMEPAGE="https://github.com/royhills/ike-scan/"
-EGIT_REPO_URI="https://github.com/royhills/ike-scan"
+HOMEPAGE="https://github.com/royhills/ike-scan"
+SRC_URI="https://github.com/royhills/ike-scan/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
IUSE="ssl"
-KEYWORDS=""
-DEPEND="
- ssl? (
- dev-libs/openssl:0=
- )
-"
-RDEPEND="
- ${DEPEND}
-"
+DEPEND="ssl? ( dev-libs/openssl:= )"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.9.5-clang-16.patch
+)
src_prepare() {
+ default
+
# Fix buffer overflow, bug #277556
sed \
-e "/MAXLINE/s:255:511:g" \
-i ike-scan.h || die
- default
-
eautoreconf
}
diff --git a/net-analyzer/nfdump/Manifest b/net-analyzer/nfdump/Manifest
index 00d4e7ade1ac..2e99529dd136 100644
--- a/net-analyzer/nfdump/Manifest
+++ b/net-analyzer/nfdump/Manifest
@@ -1,2 +1,2 @@
-DIST nfdump-1.6.23.tar.gz 568879 BLAKE2B ca844f87e02fb3761d5b470cac11beada9873b0c7e3e9ca7ccc7899d57f0cfd96329698ac84467a55d683e83ce16c2b114a571845c7cb6069addcdd5d4a43903 SHA512 e3f79af69a170985fcbd1757fab86e90840d040cf7a6214c7f9851ed59695d3844a15269904c3ba989b6b6ed2ddf29fd19a493165d3037e49aa2bb69b831f168
DIST nfdump-1.6.24.tar.gz 647945 BLAKE2B 6f054c7ccdbc6c5052d1c4655509414b9acc7de320152e932dd31d6cc9eb915b73efa29e42a212ea206c4619c9e025bfd751762808fd8136c38d4edb72f4fabf SHA512 b1e092663ce245247af721565139eb0a264918747e6c0695c59f0b70a99049e92d79674d75c248f60aa832949d7e13027887cc825e393fce7dc5571771bce1d7
+DIST nfdump-1.7.0.1.tar.gz 740435 BLAKE2B dd3d3e63aa076b32e0c9e897b40d3ee8368990792b1a483b69a448dadd7389c23df9800910baad0c5a241a480c5961616c70040fdce992b2a67e3be6680e715b SHA512 5b5da57016dc826650ba80a80a881ab89034778316f47c6797dbc902ed6af6d77cfb722356c3a1d92a4239a934178df56ff4c6cb3bf77e029232e02b905ec1a8
diff --git a/net-analyzer/nfdump/files/nfdump-1.6.19-compiler.patch b/net-analyzer/nfdump/files/nfdump-1.6.19-compiler.patch
deleted file mode 100644
index 8826c50c9dc2..000000000000
--- a/net-analyzer/nfdump/files/nfdump-1.6.19-compiler.patch
+++ /dev/null
@@ -1,21 +0,0 @@
---- a/configure.ac
-+++ b/configure.ac
-@@ -9,8 +9,6 @@
- AM_INIT_AUTOMAKE([subdir-objects])
-
- # Checks for programs.
--CFLAGS="-g -O3"
--AC_PROG_CC([clang gcc])
- AX_CHECK_C11
- CFLAGS="$CFLAGS -Wall -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wmissing-noreturn -fno-strict-aliasing"
-
---- a/bin/Makefile.am
-+++ b/bin/Makefile.am
-@@ -30,7 +30,6 @@
- LDADD = $(DEPS_LIBS)
-
- #Add extra debug info for gdb
--AM_CFLAGS = -ggdb
-
- # libnfdump sources
- output = output_util.h output_util.c output_raw.h output_raw.c
diff --git a/net-analyzer/nfdump/files/nfdump-1.6.23-autotools.patch b/net-analyzer/nfdump/files/nfdump-1.6.23-autotools.patch
deleted file mode 100644
index 65558bbe7dfa..000000000000
--- a/net-analyzer/nfdump/files/nfdump-1.6.23-autotools.patch
+++ /dev/null
@@ -1,216 +0,0 @@
-https://github.com/phaag/nfdump/commit/e6261098570f69ad973a7a4ea7aaebb1663712e8
-https://github.com/phaag/nfdump/commit/67da975f20076751bce49caf57c89ed21ed92ad0
-https://github.com/phaag/nfdump/commit/4652c2014012a81438f53cb590687c8c93419140
-
-From: Peter Haag <flow-dev@pyxis.ch>
-Date: Tue, 22 Feb 2022 10:54:19 +0100
-Subject: [PATCH] Fix issue #304 - accept CFLAGS
-
---- a/configure.ac
-+++ b/configure.ac
-@@ -8,8 +8,11 @@ AC_INIT(nfdump, 1.6.23, peter@people.ops-trust.net)
- AC_CONFIG_HEADER([config.h])
- AM_INIT_AUTOMAKE([subdir-objects])
-
-+if test "x$CFLAGS" = "x"; then
-+ CFLAGS="-g -O3"
-+fi
-+
- # Checks for programs.
--CFLAGS="-g -O3"
- AC_PROG_CC([clang gcc])
- AX_CHECK_C11
- CFLAGS="$CFLAGS -Wall -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wmissing-noreturn -fno-strict-aliasing"
-
-From: Peter Haag <peter@people.ops-trust.net>
-Date: Fri, 25 Feb 2022 09:12:27 +0100
-Subject: [PATCH] Cleanup automake files. Fixes #304.
-
---- a/configure.ac
-+++ b/configure.ac
-@@ -1,12 +1,13 @@
- # -*- Autoconf -*-
- # Process this file with autoconf to produce a configure script.
-
--AC_PREREQ(2.59)
-+AC_PREREQ([2.71])
- AC_REVISION($Revision: 244 $)dnl
--AC_INIT(nfdump, 1.6.23, peter@people.ops-trust.net)
-+AC_INIT([nfdump],[1.6.23],[peter@people.ops-trust.net])
-
--AC_CONFIG_HEADER([config.h])
-+AC_CONFIG_HEADERS([config.h])
- AM_INIT_AUTOMAKE([subdir-objects])
-+AC_CONFIG_MACRO_DIRS([m4])
-
- if test "x$CFLAGS" = "x"; then
- CFLAGS="-g -O3"
-@@ -15,7 +16,12 @@ fi
- # Checks for programs.
- AC_PROG_CC([clang gcc])
- AX_CHECK_C11
--CFLAGS="$CFLAGS -Wall -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wmissing-noreturn -fno-strict-aliasing"
-+AX_APPEND_FLAG([-Wall], [CFLAGS])
-+AX_APPEND_FLAG([-Wstrict-prototypes], [CFLAGS])
-+AX_APPEND_FLAG([-Wmissing-prototypes], [CFLAGS])
-+AX_APPEND_FLAG([-Wmissing-declarations], [CFLAGS])
-+AX_APPEND_FLAG([-Wmissing-noreturn], [CFLAGS])
-+AX_APPEND_FLAG([-fno-strict-aliasing], [CFLAGS])
-
- LT_INIT
-
-@@ -59,7 +65,7 @@ if test "${enable_fixtimebug}" = "yes" ; then
- fi
-
- AC_PROG_YACC
--AC_PROG_LEX
-+AC_PROG_LEX(yywrap)
- which $LEX > /dev/null 2>&1
- if test $? = 1; then
- AC_MSG_ERROR(No lex or flex found on system)
-@@ -312,7 +318,11 @@ AC_LINK_IFELSE(
-
- # Checks for header files.
- AC_HEADER_DIRENT
--AC_HEADER_STDC
-+# Autoupdate added the next two lines to ensure that your configure
-+# script's behavior did not change. They are probably safe to remove.
-+AC_CHECK_INCLUDES_DEFAULT
-+AC_PROG_EGREP
-+
- AC_CHECK_HEADERS(stdio_ext.h)
- AC_CHECK_HEADERS([nameser8_compat.h])
- AC_CHECK_HEADERS([features.h arpa/inet.h fcntl.h netinet/in.h fts.h stdint.h stdlib.h stddef.h string.h sys/socket.h syslog.h unistd.h iso/limits_iso.h])
-@@ -404,17 +414,14 @@ AC_CHECK_FUNCS(memcmp memcpy memmove memset)
- AC_MSG_CHECKING([for union semun])
- AC_CACHE_VAL(ac_cv_struct_semun,
- [
-- AC_TRY_COMPILE(
-- [
-+ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
- #include <sys/types.h>
- #include <sys/ipc.h>
- #include <sys/sem.h>;
-- ],
-- [
-+ ]], [[
- union semun semdat;
-- ],
-- ac_cv_struct_semun=yes, ac_cv_struct_semun=no
-- )
-+ ]])],[ac_cv_struct_semun=yes],[ac_cv_struct_semun=no
-+ ])
- ]
- )
-
-@@ -424,7 +431,7 @@ if test "$ac_cv_struct_semun" = "yes"; then
- fi
-
- AC_MSG_CHECKING(for the %z format string in printf())
--AC_TRY_RUN([
-+AC_RUN_IFELSE([AC_LANG_SOURCE([[
- #include <stdio.h>
- #include <sys/types.h>
-
-@@ -438,28 +445,38 @@ char string[16];
-
- return i == 5 ? 0 : 1;
- }
--],
--[
-+]])],[
- AC_MSG_RESULT(yes)
- AC_DEFINE([HAVE_SIZE_T_Z_FORMAT], [1],
- [Define to 1 if you have a printf() that supports the %z format string.])
--],
--[
-+],[
- AC_MSG_RESULT(no)
--],
--[
-+],[
- AC_MSG_RESULT(no)
--]
--)
-
-+])
-+
-+AC_CONFIG_FILES([Makefile bin/Makefile man/Makefile])
-+AC_CONFIG_FILES([doc/Makefile])
- AC_PATH_PROG([DOXYGEN], [doxygen], [])
- AM_CONDITIONAL([HAVE_DOXYGEN], [test -n "$DOXYGEN"])
- AM_COND_IF([HAVE_DOXYGEN], AC_CONFIG_FILES([doc/Doxyfile]))
--AC_OUTPUT(doc/Makefile)
--
--#AC_CONFIG_FILES([Makefile])
--AC_OUTPUT(Makefile bin/Makefile man/Makefile)
-+AC_OUTPUT
-
-+echo ""
-+echo "----------------------------------"
-+echo " Build Settings for ${PACKAGE_TARNAME} v${PACKAGE_VERSION}"
-+echo "----------------------------------"
-+echo " host type = $host_os"
-+echo " install dir = $prefix"
-+echo " CC = $CC"
-+echo " CFLAGS = $AM_CFLAGS $CFLAGS"
-+echo " CPPFLAGS = $AM_CPPFLAGS $CPPFLAGS"
-+echo " LDFLAGS = $AM_LDFLAGS $LDFLAGS"
-+echo " LIBS = $LIBS"
-+echo "----------------------------------"
-+echo ""
-+echo " You can run ./make now."
- echo ""
- echo "* Many thanks for using nfdump tools"
- echo "* Please send bug reports back to me: peter@people.ops-trust.net"
-
-From: Peter Haag <peter@people.ops-trust.net>
-Date: Thu, 3 Mar 2022 09:25:15 +0100
-Subject: [PATCH] Make configure.ac autoconf 2.69 compatible
-
---- a/configure.ac
-+++ b/configure.ac
-@@ -1,7 +1,7 @@
- # -*- Autoconf -*-
- # Process this file with autoconf to produce a configure script.
-
--AC_PREREQ([2.71])
-+AC_PREREQ([2.69])
- AC_REVISION($Revision: 244 $)dnl
- AC_INIT([nfdump],[1.6.23],[peter@people.ops-trust.net])
-
-@@ -47,7 +47,7 @@ if test "${enable_jnat}" = "yes" ; then
- fi
-
- if test "${enable_nsel}" = "yes" -a "${enable_jnat}" = "yes"; then
-- AC_MSG_ERROR(You can use only one of --enable-nsel or --enable-jnat. CISCO and Juniper are not compatible.)
-+ AC_MSG_ERROR([You can use only one of --enable-nsel or --enable-jnat. CISCO and Juniper are not compatible.])
- fi
-
- AC_ARG_ENABLE(nel,
-@@ -287,7 +287,6 @@ AC_SUBST(FT_INCLUDES)
- AC_SUBST(FT_LDFLAGS)
- AC_SUBST(LFLAGS)
-
--
- # Checks for libraries.
- AC_CHECK_FUNCS(gethostbyname,,[AC_CHECK_LIB(nsl,gethostbyname,,[AC_CHECK_LIB(socket,gethostbyname)])])
- AC_CHECK_FUNCS(setsockopt,,[AC_CHECK_LIB(socket,setsockopt)])
-@@ -447,8 +446,7 @@ char string[16];
- }
- ]])],[
- AC_MSG_RESULT(yes)
-- AC_DEFINE([HAVE_SIZE_T_Z_FORMAT], [1],
-- [Define to 1 if you have a printf() that supports the %z format string.])
-+ AC_DEFINE([HAVE_SIZE_T_Z_FORMAT], [1], [Define to 1 if you have a printf() that supports the %z format string.])
- ],[
- AC_MSG_RESULT(no)
- ],[
---- /dev/null
-+++ b/m4/extensions.m4
-@@ -0,0 +1,4 @@
-+dnl Define to empty for the benefit of Autoconf 2.69
-+dnl AC_USE_SYSTEM_EXTENSIONS (below) can be used unchanged from Autoconf 2.70+.
-+m4_ifndef([AC_CHECK_INCLUDES_DEFAULT],
-+ [AC_DEFUN([AC_CHECK_INCLUDES_DEFAULT], [])])
-
diff --git a/net-analyzer/nfdump/files/nfdump-1.6.23-m4-dir-automake.patch b/net-analyzer/nfdump/files/nfdump-1.6.23-m4-dir-automake.patch
deleted file mode 100644
index 755db8b7cf5d..000000000000
--- a/net-analyzer/nfdump/files/nfdump-1.6.23-m4-dir-automake.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-https://github.com/phaag/nfdump/pull/336
-
-From e882722e4e006d0440fb5a37fb051d4747e4f225 Mon Sep 17 00:00:00 2001
-From: Sam James <sam@gentoo.org>
-Date: Thu, 24 Mar 2022 22:50:13 +0000
-Subject: [PATCH] Makefile.am: add ACLOCAL_AMFLAGS
-
-Per autoconf docs [0], if using automake and AC_CONFIG_MACRO_DIR,
-we need to include ACLOCAL_AMFLAGS in Makefile.am.
-
-So, let's set ACLOCAL_AMFLAGS = -I m4.
-
-This sorts out an automake warning.
-
-Signed-off-by: Sam James <sam@gentoo.org>
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -1,3 +1,4 @@
-+ACLOCAL_AMFLAGS = -I m4
-
- SUBDIRS = . bin man doc
-
-
diff --git a/net-analyzer/nfdump/files/nfdump-1.6.23-m4-dir.patch b/net-analyzer/nfdump/files/nfdump-1.6.23-m4-dir.patch
deleted file mode 100644
index ac25ee094653..000000000000
--- a/net-analyzer/nfdump/files/nfdump-1.6.23-m4-dir.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-Variant sent upstream (configure.ac hunk irrelevant now): https://github.com/phaag/nfdump/pull/336
-https://bugs.gentoo.org/832420
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -1,3 +1,4 @@
-+ACLOCAL_AMFLAGS = -I m4
-
- SUBDIRS = . bin man doc
-
---- a/configure.ac
-+++ b/configure.ac
-@@ -7,6 +7,7 @@ AC_INIT(nfdump, 1.6.23, peter@people.ops-trust.net)
-
- AC_CONFIG_HEADER([config.h])
- AM_INIT_AUTOMAKE([subdir-objects])
-+AC_CONFIG_MACRO_DIR([m4])
-
- # Checks for programs.
- AX_CHECK_C11
diff --git a/net-analyzer/nfdump/nfdump-1.6.23.ebuild b/net-analyzer/nfdump/nfdump-1.6.23.ebuild
deleted file mode 100644
index dca53c21054e..000000000000
--- a/net-analyzer/nfdump/nfdump-1.6.23.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools
-
-DESCRIPTION="A set of tools to collect and process netflow data"
-HOMEPAGE="https://github.com/phaag/nfdump"
-SRC_URI="https://github.com/phaag/nfdump/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="amd64 x86"
-IUSE="debug doc jnat ftconv nfpcapd nfprofile nftrack nsel readpcap sflow"
-
-REQUIRED_USE="?? ( jnat nsel )"
-
-RDEPEND="
- app-arch/bzip2
- sys-libs/zlib
- ftconv? ( net-analyzer/flow-tools )
- nfpcapd? ( net-libs/libpcap )
- nfprofile? ( net-analyzer/rrdtool )
- nftrack? ( net-analyzer/rrdtool )
- readpcap? ( net-libs/libpcap )
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- sys-devel/flex
- virtual/yacc
- doc? (
- app-doc/doxygen
- media-gfx/graphviz
- )
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.6.19-compiler.patch
- "${FILESDIR}"/${PN}-1.6.19-libft.patch
- "${FILESDIR}"/${PN}-1.6.23-m4-dir.patch
-)
-
-DOCS=( AUTHORS ChangeLog README.md )
-
-src_prepare() {
- default
-
- eautoreconf
-
- if use doc; then
- doxygen -u doc/Doxyfile.in || die
- fi
-}
-
-src_configure() {
- # --without-ftconf is not handled well, bug #322201
- econf \
- $(use ftconv && echo "--enable-ftconv --with-ftpath=/usr") \
- $(use nfpcapd && echo --enable-nfpcapd) \
- $(use nfprofile && echo --enable-nfprofile) \
- $(use nftrack && echo --enable-nftrack) \
- $(use_enable debug devel) \
- $(use_enable jnat) \
- $(use_enable nsel) \
- $(use_enable readpcap) \
- $(use_enable sflow) \
- --disable-static
-}
-
-src_install() {
- default
-
- find "${ED}" -name '*.la' -delete || die
-
- newinitd "${FILESDIR}"/nfcapd.initd nfcapd
- newconfd "${FILESDIR}"/nfcapd.confd nfcapd
-
- if use doc; then
- dodoc -r doc/html
- fi
-}
diff --git a/net-analyzer/nfdump/nfdump-1.6.23-r1.ebuild b/net-analyzer/nfdump/nfdump-1.7.0.1.ebuild
index 34bb2bd90adb..db24ffe43a66 100644
--- a/net-analyzer/nfdump/nfdump-1.6.23-r1.ebuild
+++ b/net-analyzer/nfdump/nfdump-1.7.0.1.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit autotools toolchain-funcs
+inherit autotools flag-o-matic toolchain-funcs
DESCRIPTION="A set of tools to collect and process netflow data"
HOMEPAGE="https://github.com/phaag/nfdump"
@@ -19,6 +19,7 @@ REQUIRED_USE="?? ( jnat nsel )"
RDEPEND="
app-arch/bzip2
sys-libs/zlib
+ elibc_musl? ( sys-libs/fts-standalone )
ftconv? ( net-analyzer/flow-tools )
nfpcapd? ( net-libs/libpcap )
nfprofile? ( net-analyzer/rrdtool )
@@ -36,8 +37,6 @@ BDEPEND="
"
PATCHES=(
- "${FILESDIR}"/${P}-autotools.patch
- "${FILESDIR}"/${P}-m4-dir-automake.patch
"${FILESDIR}"/${PN}-1.6.19-libft.patch
)
@@ -56,6 +55,9 @@ src_prepare() {
src_configure() {
tc-export CC
+ # bug #853763
+ use elibc_musl && append-libs "-lfts"
+
# --without-ftconf is not handled well, bug #322201
econf \
$(use ftconv && echo "--enable-ftconv --with-ftpath=/usr") \
diff --git a/net-analyzer/sniffit/files/sniffit-0.5.0-implicit-func-decl.patch b/net-analyzer/sniffit/files/sniffit-0.5.0-implicit-func-decl.patch
new file mode 100644
index 000000000000..e6ee580d6e33
--- /dev/null
+++ b/net-analyzer/sniffit/files/sniffit-0.5.0-implicit-func-decl.patch
@@ -0,0 +1,50 @@
+https://github.com/resurrecting-open-source-projects/sniffit/pull/3
+
+From a05340968343d9f61f57506ed00bff0a62d3f38e Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Thu, 28 Jul 2022 12:14:44 +0100
+Subject: [PATCH] Fix -Wimplicit-function-declaration
+
+--- a/src/sn_cfgfile.c
++++ b/src/sn_cfgfile.c
+@@ -2,6 +2,7 @@
+ /* - by : Brecht Claerhout */
+ /* - improvements: Shudoh Kazuyuki */
+
++#include <ctype.h>
+ #include <stdlib.h>
+ #include <stdio.h>
+ #include <string.h>
+--- a/src/sn_generation.c
++++ b/src/sn_generation.c
+@@ -13,7 +13,9 @@
+ #include "sn_curses.h"
+ #include "sn_defines.h"
+ #include "sn_structs.h"
++#include "sn_packets.h"
+ #include "sn_generation.h"
++#include "sn_interface.h"
+
+ extern volatile int screen_busy;
+
+--- a/src/sn_interface.c
++++ b/src/sn_interface.c
+@@ -4,6 +4,7 @@
+ #include "sn_config.h"
+
+ #ifdef INCLUDE_INTERFACE
++#include <ctype.h>
+ #include <signal.h>
+ #include <termios.h>
+ #include <stdlib.h>
+--- a/src/sniffit.c
++++ b/src/sniffit.c
+@@ -3,6 +3,7 @@
+
+ #include "sn_config.h" /* Config header file */
+
++#include <ctype.h>
+ #include <unistd.h>
+ #include <signal.h>
+ #include <stdlib.h>
+
diff --git a/net-analyzer/sniffit/sniffit-0.5.ebuild b/net-analyzer/sniffit/sniffit-0.5-r1.ebuild
index 3be66ceda23e..1247440f794f 100644
--- a/net-analyzer/sniffit/sniffit-0.5.ebuild
+++ b/net-analyzer/sniffit/sniffit-0.5-r1.ebuild
@@ -1,27 +1,29 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+
inherit autotools
DESCRIPTION="Interactive Packet Sniffer"
HOMEPAGE="https://github.com/resurrecting-open-source-projects/sniffit"
SRC_URI="https://github.com/resurrecting-open-source-projects/sniffit/archive/${P}.tar.gz"
-SLOT="0"
+S="${WORKDIR}"/${PN}-${P}
+
LICENSE="BSD"
+SLOT="0"
KEYWORDS="amd64 ppc sparc x86"
RDEPEND="
net-libs/libpcap
>=sys-libs/ncurses-5.2
"
-DEPEND="
- ${RDEPEND}
-"
+DEPEND="${RDEPEND}"
+
PATCHES=(
"${FILESDIR}"/${PN}-0.4.0-tinfo.patch
+ "${FILESDIR}"/${PN}-0.5.0-implicit-func-decl.patch
)
-S=${WORKDIR}/${PN}-${P}
src_prepare() {
default