summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-arch/lxqt-archiver/Manifest1
-rw-r--r--app-arch/lxqt-archiver/lxqt-archiver-0.2.0.ebuild49
-rw-r--r--app-arch/lxqt-archiver/metadata.xml11
3 files changed, 61 insertions, 0 deletions
diff --git a/app-arch/lxqt-archiver/Manifest b/app-arch/lxqt-archiver/Manifest
new file mode 100644
index 000000000000..186a2637a7f1
--- /dev/null
+++ b/app-arch/lxqt-archiver/Manifest
@@ -0,0 +1 @@
+DIST lxqt-archiver-0.2.0.tar.xz 155912 BLAKE2B e5c92d5939d3e6d42a79804596e9acc67b007126b630cd9317df7d0d07bb8f3e27cf9ecf6e16eef3289d31ef3627b4fa870cdb5eb52a36489df1080b03509acd SHA512 478a04d0e6e4601dc342ae260c5db4178b01191cae263154dbe400b394e5cd4cb9cd8a6bab7e7c59af57d6bf20c47a5ad2663a85d0eab5f71fbaf584f7588fd7
diff --git a/app-arch/lxqt-archiver/lxqt-archiver-0.2.0.ebuild b/app-arch/lxqt-archiver/lxqt-archiver-0.2.0.ebuild
new file mode 100644
index 000000000000..dd4a15a89c32
--- /dev/null
+++ b/app-arch/lxqt-archiver/lxqt-archiver-0.2.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake xdg-utils
+
+DESCRIPTION="Qt GUI File Archiver"
+HOMEPAGE="https://lxqt.github.io/"
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2 GPL-2+"
+SLOT="0"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ >=dev-util/lxqt-build-tools-0.7.0
+"
+DEPEND="
+ dev-libs/json-glib
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ >=x11-libs/libfm-qt-0.15.0
+"
+RDEPEND="${DEPEND}"
+
+pkg_postinst() {
+ xdg_desktop_database_update
+
+ elog "Please note that this is only a graphical front-end, and additional"
+ elog "packages are needed to have support for specific file formats."
+ elog "For example, to be able to work with the 7-Zip format, the"
+ elog "'app-arch/p7zip' package may be used."
+ elog "For the full list of supported formats, see the 'README.md' file:"
+ elog "https://github.com/lxqt/lxqt-archiver/blob/master/README.md"
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}
diff --git a/app-arch/lxqt-archiver/metadata.xml b/app-arch/lxqt-archiver/metadata.xml
new file mode 100644
index 000000000000..19d4de86f7b1
--- /dev/null
+++ b/app-arch/lxqt-archiver/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>lxqt@gentoo.org</email>
+ <name>LXQt</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">lxqt/lxqt-archiver</remote-id>
+ </upstream>
+</pkgmetadata>