summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-apps/s6-portable-utils/Manifest1
-rw-r--r--sys-apps/s6-portable-utils/metadata.xml4
-rw-r--r--sys-apps/s6-portable-utils/s6-portable-utils-2.1.0.0.ebuild49
3 files changed, 54 insertions, 0 deletions
diff --git a/sys-apps/s6-portable-utils/Manifest b/sys-apps/s6-portable-utils/Manifest
index 4e527b8d7a54..d53bb671ac33 100644
--- a/sys-apps/s6-portable-utils/Manifest
+++ b/sys-apps/s6-portable-utils/Manifest
@@ -1,2 +1,3 @@
DIST s6-portable-utils-2.0.5.3.tar.gz 46300 SHA256 27be01b3d66df617ea7dbc21b55d253d5b9142463099f6944f90ef33587a2e09 SHA512 19e71457dc0ca8c1d161da36fb32902f2b8c60759745651806c9eebd19f3ec4d3d87d2d45fb226711eb16f6ae407671c363fc2a7df7d5746ecf3a4197012a122 WHIRLPOOL 1760eadf1eded5981aeb5b43df3a3c012a0b300ffed4ffdb22b51907e07962f65270763dff24937acbe7414d70f273497d8b91672360606827a002e968d2fa58
DIST s6-portable-utils-2.0.6.0.tar.gz 46972 SHA256 233b7d13766a23661cc7ed5c052f29b9c558c1d516a538a281a17da22a909d4b SHA512 822c723f112550550591afb83908bf4d62f40e88fd46eacc6d56feb4c952bcfc4bad91c988f7379323cf7997c4fb823bb837e0c433ca6947762a63a1b8681557 WHIRLPOOL efa966bb5423bb4d0e7cd56c41d899430a7b6204e99646f376b8e9acba9ec8cc7b597fb420397a8808c2f3c4bec65826701e61f1d6e452fef2004e051a4d0d35
+DIST s6-portable-utils-2.1.0.0.tar.gz 47170 SHA256 cde145b7b9d1f1685f271c45c8aed635e74221689bb8ec21a11b3e5a252d1c4e SHA512 0b18304c63180c3233a5f29e1fc24b20c9c99c8949b042244d4a5b69cf2f15049ccbeddb2c3ffc5e88ee636bcfe836568670cc1626d5517381771ee3baff10c5 WHIRLPOOL aeca14c78f8cc5e95c56a14658b6bd41f93bd7bb301b219d2b9a49034f8f565de9e5c33736b029e1d9e5c78abbca75276538b56e442cc247b5971ec5699087a7
diff --git a/sys-apps/s6-portable-utils/metadata.xml b/sys-apps/s6-portable-utils/metadata.xml
index 7ac867bbd037..1bf18c1a375e 100644
--- a/sys-apps/s6-portable-utils/metadata.xml
+++ b/sys-apps/s6-portable-utils/metadata.xml
@@ -7,6 +7,10 @@
<description>Proxied maintainer; set to assignee in all bugs</description>
</maintainer>
<maintainer type="person">
+ <email>samuel@sholland.org</email>
+ <name>Samuel Holland</name>
+ </maintainer>
+ <maintainer type="person">
<email>williamh@gentoo.org</email>
<name>William Hubbs</name>
</maintainer>
diff --git a/sys-apps/s6-portable-utils/s6-portable-utils-2.1.0.0.ebuild b/sys-apps/s6-portable-utils/s6-portable-utils-2.1.0.0.ebuild
new file mode 100644
index 000000000000..daf6246ddcce
--- /dev/null
+++ b/sys-apps/s6-portable-utils/s6-portable-utils-2.1.0.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="set of tiny portable unix utilities"
+HOMEPAGE="http://www.skarnet.org/software/s6-portable-utils/"
+SRC_URI="http://www.skarnet.org/software/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static"
+
+DEPEND=">=sys-devel/make-3.81
+ static? (
+ >=dev-libs/skalibs-2.4.0.0[static-libs]
+ )
+ !static? (
+ >=dev-libs/skalibs-2.4.0.0
+ )
+"
+RDEPEND="
+ !static? (
+ >=dev-libs/skalibs-2.4.0.0:=
+ )
+"
+
+HTML_DOCS="doc/*"
+
+src_prepare() {
+ default
+
+ # Remove QA warning about LDFLAGS addition
+ sed -i "s/tryldflag LDFLAGS_AUTO -Wl,--hash-style=both/:/" "${S}/configure" || die
+}
+
+src_configure() {
+ econf \
+ --bindir=/bin \
+ --dynlibdir=/$(get_libdir) \
+ --libdir=/usr/$(get_libdir)/${PN} \
+ --with-dynlib=/$(get_libdir) \
+ --with-lib=/usr/$(get_libdir)/skalibs \
+ --with-sysdeps=/usr/$(get_libdir)/skalibs \
+ $(use_enable static allstatic) \
+ $(use_enable static static-libc)
+}