summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-shells/autojump/autojump-22.2.4-r4.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/app-shells/autojump/autojump-22.2.4-r4.ebuild b/app-shells/autojump/autojump-22.2.4-r4.ebuild
index 3b216104a294..af56c093c198 100644
--- a/app-shells/autojump/autojump-22.2.4-r4.ebuild
+++ b/app-shells/autojump/autojump-22.2.4-r4.ebuild
@@ -27,6 +27,10 @@ src_prepare() {
-e "s:/usr/local/share:/usr/share:" \
-i bin/autojump.sh || die
+ # autojump_argparse is only there for Python 2.6 compatibility
+ sed -e "s:autojump_argparse:argparse:" \
+ -i bin/autojump || die
+
# upstream fixes to the autojump.fish script; the first patch is needed for
# the second patch to apply
epatch "${FILESDIR}/autojump-22.4.4-fix-autojump.fish-bugs.patch"
@@ -51,7 +55,7 @@ src_install() {
insinto /usr/share/zsh/site-functions
doins bin/_j
- python_foreach_impl python_domodule bin/autojump_argparse.py bin/autojump_data.py bin/autojump_utils.py
+ python_foreach_impl python_domodule bin/autojump_data.py bin/autojump_utils.py
if use python; then
python_foreach_impl python_domodule tools/autojump_ipython.py
einfo 'This tool provides "j" for ipython, please add'