summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--profiles/package.deprecated7
-rw-r--r--virtual/wireguard/wireguard-1.ebuild14
2 files changed, 21 insertions, 0 deletions
diff --git a/profiles/package.deprecated b/profiles/package.deprecated
index 55f871b9b664..93679901fd60 100644
--- a/profiles/package.deprecated
+++ b/profiles/package.deprecated
@@ -17,6 +17,13 @@
#--- END OF EXAMPLES ---
+# Jason A. Donenfeld <zx2c4@gentoo.org> (2019-12-30)
+# Directly install net-vpn/wireguard-tools and net-vpn/wireguard-modules.
+# This may be accomplished by running:
+# emerge -nO net-vpn/wireguard-tools net-vpn/wireguard-modules
+# emerge -C virtual/wireguard
+virtual/wireguard
+
# Michał Górny <mgorny@gentoo.org> (2019-12-30)
# PyPy packages have been restructured, and the virtual is no longer
# necessary. Depend on dev-python/pypy{,3} instead.
diff --git a/virtual/wireguard/wireguard-1.ebuild b/virtual/wireguard/wireguard-1.ebuild
index a4ccb1517ed3..4fa639117c92 100644
--- a/virtual/wireguard/wireguard-1.ebuild
+++ b/virtual/wireguard/wireguard-1.ebuild
@@ -13,3 +13,17 @@ RDEPEND="
tools? ( net-vpn/wireguard-tools )
module? ( net-vpn/wireguard-modules )
"
+
+pkg_postinst() {
+ ewarn
+ ewarn "This package, ${CATEGORY}/${PN}, has been deprecated, in favor of explicitly"
+ ewarn "merging the tools and the modules separately. You may accomplish this by"
+ ewarn "running:"
+ ewarn
+ ewarn " emerge -nO net-vpn/wireguard-tools net-vpn/wireguard-modules"
+ ewarn " emerge -C virtual/wireguard"
+ ewarn
+ ewarn "When Linux 5.6 comes out, net-vpn/wireguard-modules itself will be deprecated,"
+ ewarn "with its functionality having moved directly into Linux."
+ ewarn
+}