summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-php/PEAR-Archive_Tar/Manifest1
-rw-r--r--dev-php/PEAR-Archive_Tar/PEAR-Archive_Tar-1.4.3.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-php/PEAR-Archive_Tar/Manifest b/dev-php/PEAR-Archive_Tar/Manifest
index b0a604c60127..b0811f780a72 100644
--- a/dev-php/PEAR-Archive_Tar/Manifest
+++ b/dev-php/PEAR-Archive_Tar/Manifest
@@ -1 +1,2 @@
DIST Archive_Tar-1.4.2.tgz 20624 BLAKE2B 2276b19a6e5f18947d6f976db28a5869601b9b1d271e5788c74ef4704fce949c39b20811b82bb1e9c7575dd6b5ce6b0561751a560a1aaca6547415badd5188f6 SHA512 dad5872c82fb9fd961dc06d173610f60d0e05b4c05428e3410beb5a6cdf05de27704edf805e7db80c4031409af5d7d59e7abe43cef7aa11fd9d086b1c6e8e761
+DIST Archive_Tar-1.4.3.tgz 20682 BLAKE2B a2e840087178fb55719634198852d191aef24139f819e3c478883fd007f6e72f523700617c7ff2c3d92a3ebe36a237b0eb7544dfe86dec394587ee0b3743520f SHA512 62e60d59266c5d19b131f769f4d71d4cee6bf8964b0c6610c4f1381500ced582865bff26c608479b2678dda1e7407ba39a7ec84b31fed13e3875f1947ce5bd6c
diff --git a/dev-php/PEAR-Archive_Tar/PEAR-Archive_Tar-1.4.3.ebuild b/dev-php/PEAR-Archive_Tar/PEAR-Archive_Tar-1.4.3.ebuild
new file mode 100644
index 000000000000..25b31991dcc7
--- /dev/null
+++ b/dev-php/PEAR-Archive_Tar/PEAR-Archive_Tar-1.4.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="${PN/PEAR-/}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Tar file management class"
+HOMEPAGE="http://pear.php.net/package/${MY_PN}"
+SRC_URI="http://pear.php.net/get/${MY_P}.tgz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+# bzip2 and zlib are needed for compressed tarballs, and there's one
+# call to preg_match to test paths against a pattern of files and
+# directories that will be ignored.
+RDEPEND="dev-lang/php:*[bzip2,pcre(+),zlib]"
+PDEPEND="dev-php/PEAR-PEAR"
+DEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ insinto /usr/share/php
+ doins -r Archive
+
+ dodoc docs/*
+}