summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-tcltk/tdom/files/tdom-0.9.2-nothreads.patch11
-rw-r--r--dev-tcltk/tdom/tdom-0.9.2.ebuild5
2 files changed, 15 insertions, 1 deletions
diff --git a/dev-tcltk/tdom/files/tdom-0.9.2-nothreads.patch b/dev-tcltk/tdom/files/tdom-0.9.2-nothreads.patch
new file mode 100644
index 000000000000..b24c9821f0d4
--- /dev/null
+++ b/dev-tcltk/tdom/files/tdom-0.9.2-nothreads.patch
@@ -0,0 +1,11 @@
+--- a/generic/tdomDecls.h 2021-12-31 20:52:18.070370435 +0100
++++ b/generic/tdomDecls.h 2021-12-31 20:53:45.892045820 +0100
+@@ -63,7 +63,7 @@
+ EXTERN domDocument * tcldom_getDocumentFromName(Tcl_Interp *interp,
+ char *docName, char **errMsg);
+ /* 18 */
+-EXTERN SchemaData * tdomGetSchemadata(void);
++EXTERN SchemaData * tdomGetSchemadata(Tcl_Interp *interp);
+
+ typedef struct TdomStubs {
+ int magic;
diff --git a/dev-tcltk/tdom/tdom-0.9.2.ebuild b/dev-tcltk/tdom/tdom-0.9.2.ebuild
index c8dbe69542c7..29ad01876f00 100644
--- a/dev-tcltk/tdom/tdom-0.9.2.ebuild
+++ b/dev-tcltk/tdom/tdom-0.9.2.ebuild
@@ -23,7 +23,10 @@ RDEPEND="${DEPEND}"
S="${WORKDIR}"/${P}-src
-PATCHES=( "${FILESDIR}"/${P}-useCC.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}-useCC.patch
+ "${FILESDIR}"/${P}-nothreads.patch
+)
src_prepare() {
append-libs -lm