summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-misc/xkeyboard-config/Manifest1
-rw-r--r--x11-misc/xkeyboard-config/xkeyboard-config-2.20.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/x11-misc/xkeyboard-config/Manifest b/x11-misc/xkeyboard-config/Manifest
index 1268f636790f..a198d8e65582 100644
--- a/x11-misc/xkeyboard-config/Manifest
+++ b/x11-misc/xkeyboard-config/Manifest
@@ -3,3 +3,4 @@ DIST xkeyboard-config-2.16.tar.bz2 968663 SHA256 1e8a1f212c96b7f71ca0b05da361cac
DIST xkeyboard-config-2.17.tar.bz2 973675 SHA256 dec6be44bd31775cdc1ab95bfd75d5f2c0055613eeca8b4e9c6480b183430701 SHA512 375a38fde9befef0c779b7593c17e3889abf5cf73c66e9ff37f58ea65ca6065bad2835a4187321b88187a1922e47ae086663851906c6082860da8096c7e828b1 WHIRLPOOL 6e9187a4fae546af6fc7707a100fbeea22980cb8ae1217e57263c02ef1d79a1f19e5d163f90a3ecb3a5cb0c9e2a3c5aa981e2fb86b51af876297d748127a4761
DIST xkeyboard-config-2.18.tar.bz2 978557 SHA256 c41d917d6c8a59feb7ccbda51c40a6ada824fdd1e9684b52dd48c9530617ddd0 SHA512 5415fadf66a8e2b671029f4d1cd6726a522d347abe87a0f4f33fa85662dd2dc2348fc7402c53281ad2a8615c61eb447760d16d7dac426df19d0834d05b81f548 WHIRLPOOL 6b0e05f606ee7f41ee1ae7ed90d28a3b7ae973583177fe5b347c72ac2faa210aa25063bc70157168b2b38aa357559f2ff95f8242bcf36b8118fb067fa624fc60
DIST xkeyboard-config-2.19.tar.bz2 985697 SHA256 83dfd186b9eb9ced69e01d8d8e2f15b6a79b2e30124874ef086f2d3048f45827 SHA512 a928a334375da16f614e92b6d557bc3c199f7bb26e3f0a1cceec406b3b2d48a6789074fe7e93c938d2bcc2683275df37443800840b921524498a869a3f5721de WHIRLPOOL 3872377f8ccd6bce9f1f24ae91799a11a4b58510e34aa020fb862ff142e1298b0f25f22cd88266e1a8b74c0633af776bad998e360527ee9cf1fe31d92ef5a2b7
+DIST xkeyboard-config-2.20.tar.bz2 978275 SHA256 d1bfc72553c4e3ef1cd6f13eec0488cf940498b612ab8a0b362e7090c94bc134 SHA512 29584096874cf8f1444ed00374150fb186e9a74221b384d779bcf01c0762977f8a6a1b3dfa37acd560667a79cc80d4c0d39729b7dc21809520a7254026439db4 WHIRLPOOL f03b1e05e3c2897cab96bf569e97bb1095f13a8ce1eb2aaae4ae0ff1a588974c9e7e5bd066026f95a2c4939d0bc151aad77a233b7dbf994e3caeb50a5210f539
diff --git a/x11-misc/xkeyboard-config/xkeyboard-config-2.20.ebuild b/x11-misc/xkeyboard-config/xkeyboard-config-2.20.ebuild
new file mode 100644
index 000000000000..66575b1a60e1
--- /dev/null
+++ b/x11-misc/xkeyboard-config/xkeyboard-config-2.20.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+XORG_STATIC=no
+inherit xorg-2
+
+EGIT_REPO_URI="git://anongit.freedesktop.org/git/xkeyboard-config"
+
+DESCRIPTION="X keyboard configuration database"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/XKeyboardConfig"
+[[ ${PV} == *9999* ]] || SRC_URI="${XORG_BASE_INDIVIDUAL_URI}/data/${PN}/${P}.tar.bz2"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="!<x11-apps/xkbcomp-1.2.3
+ !<x11-libs/libX11-1.4.3"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ >=x11-proto/xproto-7.0.20"
+
+XORG_CONFIGURE_OPTIONS=(
+ --with-xkb-base="${EPREFIX}/usr/share/X11/xkb"
+ --enable-compat-rules
+ # do not check for runtime deps
+ --disable-runtime-deps
+ --with-xkb-rules-symlink=xorg
+)
+
+src_prepare() {
+ xorg-2_src_prepare
+ if [[ ${XORG_EAUTORECONF} != no ]]; then
+ intltoolize --copy --automake || die
+ fi
+}
+
+src_compile() {
+ # cleanup to make sure .dir files are regenerated
+ # bug #328455 c#26
+ xorg-2_src_compile clean
+ xorg-2_src_compile
+}