summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--kde-plasma/xdg-desktop-portal-kde/Manifest1
-rw-r--r--kde-plasma/xdg-desktop-portal-kde/xdg-desktop-portal-kde-5.20.5.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/kde-plasma/xdg-desktop-portal-kde/Manifest b/kde-plasma/xdg-desktop-portal-kde/Manifest
index 593429aa5072..13ca14d44d03 100644
--- a/kde-plasma/xdg-desktop-portal-kde/Manifest
+++ b/kde-plasma/xdg-desktop-portal-kde/Manifest
@@ -1,2 +1,3 @@
DIST xdg-desktop-portal-kde-5.19.5.tar.xz 76348 BLAKE2B d3205542ec76bd6c9fa4ae5076d0716c1f201f8c90aeeb61dfcaf9010ada0b21a3e80cff70089077646059d56d19033f8ae887b34c9f30c54b8190d559df0a09 SHA512 5d82e5a1553e9fcb471895e356a23915cbad1215ae1fff5fa6fac6f1673af4c406171131222a88a13eee847dc0d99f8bab00dac1849dfa6844b1672ae7545bb7
DIST xdg-desktop-portal-kde-5.20.4.tar.xz 81796 BLAKE2B de9f7a2657b80e1cb5f78aae6edd57885762117d8cfbddac4ea8fef379417c94ec0355a8726fd91c4e652f1825a77023160e45950018dd5b7f79665343749357 SHA512 60cc023dd7b5738d3a5ba710a3f0e8b2e3fbca2d4d4c832ce0842c85e2aafc30c82dc1242a327f2502867e98b666c554184e579b779fbb59153021117ecfdcf9
+DIST xdg-desktop-portal-kde-5.20.5.tar.xz 81876 BLAKE2B 9a0a8052a7a7d9d0200723440176bef37ae6e29417ccea67b222096f0b65e3c371ad83071d93ab05ec6d7de377383e61c126da3775f31189ff1bdd3c4a947933 SHA512 618abd6182e561664b10bd751792622dd88f05932c88505e141ee143e475b228727d2daa509bf113906a97ffc507cbd11f51e15b729f2e55210d9c0000f742a1
diff --git a/kde-plasma/xdg-desktop-portal-kde/xdg-desktop-portal-kde-5.20.5.ebuild b/kde-plasma/xdg-desktop-portal-kde/xdg-desktop-portal-kde-5.20.5.ebuild
new file mode 100644
index 000000000000..5b8e46268ca4
--- /dev/null
+++ b/kde-plasma/xdg-desktop-portal-kde/xdg-desktop-portal-kde-5.20.5.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KFMIN=5.74.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=5.15.1
+inherit ecm kde.org
+
+DESCRIPTION="Backend implementation for xdg-desktop-portal that is using Qt/KDE Frameworks"
+
+LICENSE="LGPL-2+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+COMMON_DEPEND="
+ >=dev-libs/wayland-1.15
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtprintsupport-${QTMIN}:5[cups]
+ >=dev-qt/qtwayland-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kdeclarative-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kirigami-${KFMIN}:5
+ >=kde-frameworks/knotifications-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/plasma-${KFMIN}:5
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-libs/plasma-wayland-protocols-1.1.1
+ >=dev-qt/qtconcurrent-${QTMIN}:5
+ >=kde-frameworks/kwayland-${KFMIN}:5
+"
+RDEPEND="${COMMON_DEPEND}
+ sys-apps/xdg-desktop-portal
+"