summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-firmware/ipxe/Manifest1
-rw-r--r--sys-firmware/ipxe/files/ipxe-1.0.0_p20160620-no-pie.patch32
-rw-r--r--sys-firmware/ipxe/ipxe-1.0.0_p20160620.ebuild112
3 files changed, 145 insertions, 0 deletions
diff --git a/sys-firmware/ipxe/Manifest b/sys-firmware/ipxe/Manifest
index d5227c3de6f0..9a80a574fe45 100644
--- a/sys-firmware/ipxe/Manifest
+++ b/sys-firmware/ipxe/Manifest
@@ -1 +1,2 @@
DIST ipxe-1.0.0_p20130925-cba22d3.tar.bz2 2240189 SHA256 c9c819bac8a925aad30ac88a23a86dd5591a9c31846058e77465d05551fc6189 SHA512 a098d3fc0f68067be281b9c3654bb1b0be1b9d397327b55b36b17e69faf03ce6117d0278552c06990a5020e4ece7acac168d975b3c7bfce3b6865dea1fd1d8dd WHIRLPOOL 11442ea81032b4c9c00d3c1346761163cbcf2db2bc957bfbaba74c7f9109136bf5334e26752f9d10a8ed0f093ae39fd28e4152d522aa4dd86e4d1c05695d7d3a
+DIST ipxe-1.0.0_p20160620-694c18a.tar.bz2 2839663 SHA256 96398c7d80fdcc0e19763b55dc7a38eed8f227546f9bc5db95b7a8c75df9b14e SHA512 67657dabe09f497c270cca16391669c89032112c1496b54009e2f1e8a477904d758476d4e465973aa0b6fc764be48ed6421607189aaea76e23fa0da6e9c8add5 WHIRLPOOL 945f6d366c96c47ef1df3e9732c3a1131dcab0c6290bb52e120f7af22fce546c8592e925bbb91b0903f8e9cb8d1c2f05431a64b68415273377305121e75595c5
diff --git a/sys-firmware/ipxe/files/ipxe-1.0.0_p20160620-no-pie.patch b/sys-firmware/ipxe/files/ipxe-1.0.0_p20160620-no-pie.patch
new file mode 100644
index 000000000000..6abc8c6715ab
--- /dev/null
+++ b/sys-firmware/ipxe/files/ipxe-1.0.0_p20160620-no-pie.patch
@@ -0,0 +1,32 @@
+https://bugs.gentoo.org/585752
+
+From cea213034635e4d765b2f362057b696febbe509f Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Tue, 21 Jun 2016 00:47:32 -0400
+Subject: [PATCH] [build] fix PIE disable flag
+
+The flag is "-no-pie", not "-nopie".
+
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+---
+ src/arch/i386/Makefile | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/arch/i386/Makefile b/src/arch/i386/Makefile
+index fe3adc9ce436..59ad25b6e0af 100644
+--- a/src/arch/i386/Makefile
++++ b/src/arch/i386/Makefile
+@@ -75,8 +75,8 @@ CFLAGS += -Ui386
+ # output on stderr instead of checking the exit status.
+ #
+ ifeq ($(CCTYPE),gcc)
+-PIE_TEST = [ -z "`$(CC) -fno-PIE -nopie -x c -c /dev/null -o /dev/null 2>&1`" ]
+-PIE_FLAGS := $(shell $(PIE_TEST) && $(ECHO) '-fno-PIE -nopie')
++PIE_TEST = [ -z "`$(CC) -fno-PIE -no-pie -x c -c /dev/null -o /dev/null 2>&1`" ]
++PIE_FLAGS := $(shell $(PIE_TEST) && $(ECHO) '-fno-PIE -no-pie')
+ WORKAROUND_CFLAGS += $(PIE_FLAGS)
+ endif
+
+--
+2.8.2
+
diff --git a/sys-firmware/ipxe/ipxe-1.0.0_p20160620.ebuild b/sys-firmware/ipxe/ipxe-1.0.0_p20160620.ebuild
new file mode 100644
index 000000000000..b05f96452ee3
--- /dev/null
+++ b/sys-firmware/ipxe/ipxe-1.0.0_p20160620.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit toolchain-funcs eutils savedconfig
+
+GIT_REV="694c18addc0dfdf51369f6d598dd0c8ca4bf2861"
+GIT_SHORT=${GIT_REV:0:7}
+
+DESCRIPTION="Open source network boot (PXE) firmware"
+HOMEPAGE="http://ipxe.org/"
+SRC_URI="https://git.ipxe.org/ipxe.git/snapshot/${GIT_REV}.tar.bz2 -> ${P}-${GIT_SHORT}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+# TODO: Add arm/arm64 once figure out how to build w/out including
+# all the x86-specific drivers (that use I/O insns).
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="efi ipv6 iso lkrn +qemu undi usb vmware"
+
+DEPEND="app-arch/xz-utils
+ dev-lang/perl
+ sys-libs/zlib
+ iso? (
+ sys-boot/syslinux
+ virtual/cdrtools
+ )"
+RDEPEND=""
+
+S="${WORKDIR}/ipxe-${GIT_SHORT}/src"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-no-pie.patch #585752
+}
+
+src_configure() {
+ cat <<-EOF > "${S}"/config/local/general.h
+#undef BANNER_TIMEOUT
+#define BANNER_TIMEOUT 0
+EOF
+
+ use ipv6 && echo "#define NET_PROTO_IPV6" >> "${S}"/config/local/general.h
+
+ if use vmware; then
+ cat <<-EOF >> "${S}"/config/local/general.h
+#define VMWARE_SETTINGS
+#define CONSOLE_VMWARE
+EOF
+ fi
+
+ restore_config config/local/general.h
+
+ tc-ld-disable-gold
+}
+
+ipxemake() {
+ # Q='' makes the build verbose since that's what everyone loves now
+ emake Q='' \
+ CC="$(tc-getCC)" \
+ LD="$(tc-getLD)" \
+ AS="$(tc-getAS)" \
+ AR="$(tc-getAR)" \
+ NM="$(tc-getNM)" \
+ OBJCOPY="$(tc-getOBJCOPY)" \
+ RANLIB="$(tc-getRANLIB)" \
+ OBJDUMP="$(tc-getOBJDUMP)" \
+ HOST_CC="$(tc-getBUILD_CC)" \
+ "$@"
+}
+
+src_compile() {
+ export NO_WERROR=1
+ if use qemu; then
+ ipxemake bin/808610de.rom # pxe-e1000.rom (old)
+ ipxemake bin/8086100e.rom # pxe-e1000.rom
+ ipxemake bin/80861209.rom # pxe-eepro100.rom
+ ipxemake bin/10500940.rom # pxe-ne2k_pci.rom
+ ipxemake bin/10222000.rom # pxe-pcnet.rom
+ ipxemake bin/10ec8139.rom # pxe-rtl8139.rom
+ ipxemake bin/1af41000.rom # pxe-virtio.rom
+ fi
+
+ if use vmware; then
+ ipxemake bin/8086100f.mrom # e1000
+ ipxemake bin/808610d3.mrom # e1000e
+ ipxemake bin/10222000.mrom # vlance
+ ipxemake bin/15ad07b0.rom # vmxnet3
+ fi
+
+ use efi && ipxemake PLATFORM=efi BIN=bin-efi bin-efi/ipxe.efi
+ use iso && ipxemake bin/ipxe.iso
+ use undi && ipxemake bin/undionly.kpxe
+ use usb && ipxemake bin/ipxe.usb
+ use lkrn && ipxemake bin/ipxe.lkrn
+}
+
+src_install() {
+ insinto /usr/share/ipxe/
+
+ if use qemu || use vmware; then
+ doins bin/*.rom
+ fi
+ use vmware && doins bin/*.mrom
+ use efi && doins bin-efi/*.efi
+ use iso && doins bin/*.iso
+ use undi && doins bin/*.kpxe
+ use usb && doins bin/*.usb
+ use lkrn && doins bin/*.lkrn
+
+ save_config config/local/general.h
+}