summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-firewall/ipt_netflow/ipt_netflow-2.3_p20190619.ebuild4
-rw-r--r--net-firewall/ipt_netflow/ipt_netflow-9999.ebuild2
2 files changed, 3 insertions, 3 deletions
diff --git a/net-firewall/ipt_netflow/ipt_netflow-2.3_p20190619.ebuild b/net-firewall/ipt_netflow/ipt_netflow-2.3_p20190619.ebuild
index 3a1ad78c15f5..5f49f78b07df 100644
--- a/net-firewall/ipt_netflow/ipt_netflow-2.3_p20190619.ebuild
+++ b/net-firewall/ipt_netflow/ipt_netflow-2.3_p20190619.ebuild
@@ -34,7 +34,7 @@ pkg_setup() {
BUILD_TARGETS="all"
MODULE_NAMES="ipt_NETFLOW(ipt_netflow:${S})"
IPT_LIB="/usr/$(get_libdir)/xtables"
- local CONFIG_CHECK="~IP_NF_IPTABLES"
+ local CONFIG_CHECK="~IP_NF_IPTABLES VLAN_8021Q"
use debug && CONFIG_CHECK+=" ~DEBUG_FS"
use natevents && CONFIG_CHECK+=" NF_CONNTRACK_EVENTS NF_NAT_NEEDED"
linux-mod_pkg_setup
@@ -50,7 +50,7 @@ src_prepare() {
default
# Fix incorrect module version in sources
- sed -i -e "/IPT_NETFLOW_VERSION/s/2.2/${PV}/" ipt_NETFLOW.c || die
+ sed -i -e "/IPT_NETFLOW_VERSION/s/2.3/${PV}/" ipt_NETFLOW.c || die
# Checking for directory is enough
sed -i -e 's:-s /etc/snmp/snmpd.conf:-d /etc/snmp:' configure || die
diff --git a/net-firewall/ipt_netflow/ipt_netflow-9999.ebuild b/net-firewall/ipt_netflow/ipt_netflow-9999.ebuild
index 2a4bba4304bc..71ba1b74afbf 100644
--- a/net-firewall/ipt_netflow/ipt_netflow-9999.ebuild
+++ b/net-firewall/ipt_netflow/ipt_netflow-9999.ebuild
@@ -34,7 +34,7 @@ pkg_setup() {
BUILD_TARGETS="all"
MODULE_NAMES="ipt_NETFLOW(ipt_netflow:${S})"
IPT_LIB="/usr/$(get_libdir)/xtables"
- local CONFIG_CHECK="~IP_NF_IPTABLES"
+ local CONFIG_CHECK="~IP_NF_IPTABLES VLAN_8021Q"
use debug && CONFIG_CHECK+=" ~DEBUG_FS"
use natevents && CONFIG_CHECK+=" NF_CONNTRACK_EVENTS NF_NAT_NEEDED"
linux-mod_pkg_setup