summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-sound/qsynth/Manifest1
-rw-r--r--media-sound/qsynth/qsynth-0.9.2.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/media-sound/qsynth/Manifest b/media-sound/qsynth/Manifest
index b7d8b93ebcf4..cfb8ef799d81 100644
--- a/media-sound/qsynth/Manifest
+++ b/media-sound/qsynth/Manifest
@@ -1 +1,2 @@
DIST qsynth-0.9.1.tar.gz 393897 BLAKE2B f63766614d821409cd12e418e36b8dbd739da8e2cd7deae91c2b00dd4f5ba2f447a3ca19c3829de3282e368baa37567333be051641221300d13dd7948d762008 SHA512 70bba332b90963d1c1da18fb3de8f05544fed3406c2144b6ed78cf93720cbcb684ff367d7ef4bc80be94ebea060b38753ae0cb183e85f96f127014c08de701b0
+DIST qsynth-0.9.2.tar.gz 394009 BLAKE2B 9560efe95992fc6e992871c8057898e1acac46718534c7e79060dde4d1519f9fd4798385812f384c97a764676e3e1005ebe24708545db3dfb9f8e08973f07441 SHA512 ab9a2268e3926439e4784c8dc2511d7c39aa2bfb97ffb7bb34f6761f1e859d1ea53f9f6da4d5c31395c6c03dc250b74c8c250b5d71321f2a151b75ec636be3d6
diff --git a/media-sound/qsynth/qsynth-0.9.2.ebuild b/media-sound/qsynth/qsynth-0.9.2.ebuild
new file mode 100644
index 000000000000..59c6e5666ca2
--- /dev/null
+++ b/media-sound/qsynth/qsynth-0.9.2.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake desktop qmake-utils xdg
+
+DESCRIPTION="Qt application to control FluidSynth"
+HOMEPAGE="https://qsynth.sourceforge.io/"
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://git.code.sf.net/p/qsynth/code"
+ inherit git-r3
+else
+ SRC_URI="mirror://sourceforge/qsynth/${P}.tar.gz"
+ KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+alsa debug jack pulseaudio"
+
+REQUIRED_USE="|| ( alsa jack pulseaudio )"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+"
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+ media-sound/fluidsynth:=[jack?,alsa?,pulseaudio?]
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-0.9.1-cmake-no-git-version.patch" )
+
+src_prepare() {
+ cmake_src_prepare
+
+ sed -e "/^find_package.*QT/s/Qt6 //" -i CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCONFIG_DEBUG=$(usex debug 1 0)
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ # The desktop file is invalid, and we also change the command
+ # depending on useflags
+ rm "${D}/usr/share/applications/qsynth.desktop" || die
+
+ local cmd
+ if use jack; then
+ cmd="qsynth"
+ elif use pulseaudio; then
+ cmd="qsynth -a pulseaudio"
+ elif use alsa; then
+ cmd="qsynth -a alsa"
+ else
+ cmd="qsynth -a oss"
+ fi
+
+ make_desktop_entry "${cmd}" Qsynth qsynth
+}