summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-apps/dmapi/dmapi-2.2.12.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/sys-apps/dmapi/dmapi-2.2.12.ebuild b/sys-apps/dmapi/dmapi-2.2.12.ebuild
deleted file mode 100644
index 7b357aa2f049..000000000000
--- a/sys-apps/dmapi/dmapi-2.2.12.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="4"
-
-inherit toolchain-funcs multilib
-
-DESCRIPTION="XFS data management API library"
-HOMEPAGE="http://oss.sgi.com/projects/xfs/"
-SRC_URI="ftp://oss.sgi.com/projects/xfs/cmd_tars/${P}.tar.gz
- ftp://oss.sgi.com/projects/xfs/previous/cmd_tars/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86"
-IUSE="static-libs"
-
-RDEPEND="sys-fs/xfsprogs"
-DEPEND="${RDEPEND}"
-
-src_prepare() {
- sed -i \
- -e "/^PKG_DOC_DIR/s:@pkg_name@:${PF}:" \
- include/builddefs.in \
- || die
-}
-
-src_configure() {
- export OPTIMIZER=${CFLAGS}
- export DEBUG=-DNDEBUG
-
- econf \
- --libexecdir=/usr/$(get_libdir) \
- $(use_enable static-libs static)
-}
-
-src_install() {
- emake DESTDIR="${D}" install install-dev
- gen_usr_ldscript -a dm
- find "${ED}"/usr '(' -name '*.la' -o -name COPYING ')' -delete
-}