summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-plugins/wmmsg/files/wmmsg-1.0.1-list.patch12
-rw-r--r--x11-plugins/wmmsg/wmmsg-1.0.1-r2.ebuild37
2 files changed, 43 insertions, 6 deletions
diff --git a/x11-plugins/wmmsg/files/wmmsg-1.0.1-list.patch b/x11-plugins/wmmsg/files/wmmsg-1.0.1-list.patch
index da54e7a6d7db..76d2e26fbc61 100644
--- a/x11-plugins/wmmsg/files/wmmsg-1.0.1-list.patch
+++ b/x11-plugins/wmmsg/files/wmmsg-1.0.1-list.patch
@@ -1,6 +1,6 @@
-diff -Naur src/wmgeneral.orig/list.c src/wmgeneral/list.c
---- src/wmgeneral.orig/list.c 2016-01-04 13:03:23.206828813 +0100
-+++ src/wmgeneral/list.c 2016-01-04 13:03:32.358832037 +0100
+diff -Naur wmmsg-1.0.1/src/wmgeneral.orig/list.c wmmsg-1.0.1/src/wmgeneral/list.c
+--- wmmsg-1.0.1/src/wmgeneral.orig/list.c 2016-01-04 13:03:23.206828813 +0100
++++ wmmsg-1.0.1/src/wmgeneral/list.c 2016-01-04 13:03:32.358832037 +0100
@@ -38,7 +38,7 @@
/* Return a cons cell produced from (head . tail) */
@@ -85,9 +85,9 @@ diff -Naur src/wmgeneral.orig/list.c src/wmgeneral/list.c
{
while (list)
{
-diff -Naur src/wmgeneral.orig/list.h src/wmgeneral/list.h
---- src/wmgeneral.orig/list.h 2016-01-04 13:03:23.206828813 +0100
-+++ src/wmgeneral/list.h 2016-01-04 13:03:46.741837100 +0100
+diff -Naur wmmsg-1.0.1/src/wmgeneral.orig/list.h wmmsg-1.0.1/src/wmgeneral/list.h
+--- wmmsg-1.0.1/src/wmgeneral.orig/list.h 2016-01-04 13:03:23.206828813 +0100
++++ wmmsg-1.0.1/src/wmgeneral/list.h 2016-01-04 13:03:46.741837100 +0100
@@ -29,12 +29,6 @@
#ifndef __LIST_H_
#define __LIST_H_
diff --git a/x11-plugins/wmmsg/wmmsg-1.0.1-r2.ebuild b/x11-plugins/wmmsg/wmmsg-1.0.1-r2.ebuild
new file mode 100644
index 000000000000..68eb8e3fbe86
--- /dev/null
+++ b/x11-plugins/wmmsg/wmmsg-1.0.1-r2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit autotools
+
+DESCRIPTION="universal visual notification dockapp"
+HOMEPAGE="http://swapspace.net/~matt/wmmsg"
+SRC_URI="http://swapspace.net/~matt/wmmsg/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2
+ media-libs/imlib2[X]
+ x11-libs/libXpm
+ x11-libs/libXext
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ x11-libs/libXt"
+
+DOCS=( AUTHORS ChangeLog README wmmsgrc )
+PATCHES=(
+ "${FILESDIR}"/${P}-use_gtk2.patch
+ "${FILESDIR}"/${P}-alt-desktop.patch
+ "${FILESDIR}"/${P}-list.patch
+ )
+
+src_prepare() {
+ default
+
+ eautoreconf
+}