summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-apps/coreutils/coreutils-8.30.ebuild6
-rw-r--r--sys-apps/coreutils/coreutils-8.31-r1.ebuild6
-rw-r--r--sys-apps/coreutils/coreutils-8.31.ebuild6
3 files changed, 18 insertions, 0 deletions
diff --git a/sys-apps/coreutils/coreutils-8.30.ebuild b/sys-apps/coreutils/coreutils-8.30.ebuild
index 91ea2d3a06db..6c40cc430002 100644
--- a/sys-apps/coreutils/coreutils-8.30.ebuild
+++ b/sys-apps/coreutils/coreutils-8.30.ebuild
@@ -54,6 +54,12 @@ RDEPEND+="
!<app-forensics/tct-1.18-r1
!<net-fs/netatalk-2.0.3-r4"
+python_check_deps() {
+ if use test; then
+ has_version --host-root "dev-python/pyinotify[${PYTHON_USEDEP}]"
+ fi
+}
+
pkg_setup() {
if use test ; then
python-any-r1_pkg_setup
diff --git a/sys-apps/coreutils/coreutils-8.31-r1.ebuild b/sys-apps/coreutils/coreutils-8.31-r1.ebuild
index 643aa3aeeca6..5860f7daa1b5 100644
--- a/sys-apps/coreutils/coreutils-8.31-r1.ebuild
+++ b/sys-apps/coreutils/coreutils-8.31-r1.ebuild
@@ -52,6 +52,12 @@ RDEPEND+="
!<app-forensics/tct-1.18-r1
!<net-fs/netatalk-2.0.3-r4"
+python_check_deps() {
+ if use test; then
+ has_version --host-root "dev-python/pyinotify[${PYTHON_USEDEP}]"
+ fi
+}
+
pkg_setup() {
if use test ; then
python-any-r1_pkg_setup
diff --git a/sys-apps/coreutils/coreutils-8.31.ebuild b/sys-apps/coreutils/coreutils-8.31.ebuild
index 565e641c8b48..eb8a90e46999 100644
--- a/sys-apps/coreutils/coreutils-8.31.ebuild
+++ b/sys-apps/coreutils/coreutils-8.31.ebuild
@@ -54,6 +54,12 @@ RDEPEND+="
!<app-forensics/tct-1.18-r1
!<net-fs/netatalk-2.0.3-r4"
+python_check_deps() {
+ if use test; then
+ has_version --host-root "dev-python/pyinotify[${PYTHON_USEDEP}]"
+ fi
+}
+
pkg_setup() {
if use test ; then
python-any-r1_pkg_setup