summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-php/PEAR-Image_Color2/PEAR-Image_Color2-0.1.5-r1.ebuild28
-rw-r--r--dev-php/PEAR-Image_Color2/PEAR-Image_Color2-0.1.5.ebuild13
2 files changed, 28 insertions, 13 deletions
diff --git a/dev-php/PEAR-Image_Color2/PEAR-Image_Color2-0.1.5-r1.ebuild b/dev-php/PEAR-Image_Color2/PEAR-Image_Color2-0.1.5-r1.ebuild
new file mode 100644
index 000000000000..657a45b11c2a
--- /dev/null
+++ b/dev-php/PEAR-Image_Color2/PEAR-Image_Color2-0.1.5-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit php-pear-r2
+
+DESCRIPTION="Color conversion and mixing for PHP5"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+DEPEND="test? ( >=dev-php/phpunit-5 )"
+
+src_prepare() {
+ # Modernize tests
+ sed -i -e "/require_once 'PHPUnit\/Framework.php';/d" \
+ -e "s/assertType('\(Image_[a-zA-Z2_]*\)',/assertInstanceOf(\1::class,/" \
+ -e "s/assertType('array',/assertInternalType('array',/" \
+ -e "s/assertType('string',/assertInternalType('string',/" \
+ tests/*.php tests/Model/*.php || die
+ default
+}
+
+src_test() {
+ phpunit tests/AllTests.php || die
+}
diff --git a/dev-php/PEAR-Image_Color2/PEAR-Image_Color2-0.1.5.ebuild b/dev-php/PEAR-Image_Color2/PEAR-Image_Color2-0.1.5.ebuild
deleted file mode 100644
index 395133b26bca..000000000000
--- a/dev-php/PEAR-Image_Color2/PEAR-Image_Color2-0.1.5.ebuild
+++ /dev/null
@@ -1,13 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-
-inherit php-pear-r1
-
-DESCRIPTION="Color conversion and mixing for PHP5"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""