summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--kde-plasma/plasma-integration/Manifest1
-rw-r--r--kde-plasma/plasma-integration/plasma-integration-5.21.0.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/kde-plasma/plasma-integration/Manifest b/kde-plasma/plasma-integration/Manifest
index 574dfc2c6a67..3c95b8caa3fb 100644
--- a/kde-plasma/plasma-integration/Manifest
+++ b/kde-plasma/plasma-integration/Manifest
@@ -1 +1,2 @@
DIST plasma-integration-5.20.5.tar.xz 59740 BLAKE2B 8c6e054db3047093556ac9549ebe28e6270001838f28eea92138f4acc02c79235f6c0ab8d82de764dae16efa81cc7ff7519736935bd77153612ee035f7abf337 SHA512 fa0806c756d394ab6f419252396f9d0a18652ed652adcb016dd2885f5238df843814f4661c63b193805834dcd43cb346f69ce33339520229c215d2ff45a24604
+DIST plasma-integration-5.21.0.tar.xz 60936 BLAKE2B 8f1cde5275dafc8e19a40205df459db74b4d452e6069bb5af19eb408b859eb6456fd5ee1aad24bab6137f921ede2aabbcb6a34e7423a2bdd604884aa45d11852 SHA512 723338e7cdc4e62199f0d1eb30d2e08ef6c0fabbbbac98d90a7503c77a336bc07c7341acb886bb7f6ea412ea094c785b70bb2a343bfe056508eae2ef257ccfd8
diff --git a/kde-plasma/plasma-integration/plasma-integration-5.21.0.ebuild b/kde-plasma/plasma-integration/plasma-integration-5.21.0.ebuild
new file mode 100644
index 000000000000..30c2bb013da9
--- /dev/null
+++ b/kde-plasma/plasma-integration/plasma-integration-5.21.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KFMIN=5.78.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=5.15.2
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="Qt Platform Theme integration plugins for the Plasma workspaces"
+
+LICENSE="LGPL-2+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+# requires running kde environment
+RESTRICT+=" test"
+
+DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5=[dbus]
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtx11extras-${QTMIN}:5
+ >=kde-frameworks/kcompletion-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kiconthemes-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kjobwidgets-${KFMIN}:5
+ >=kde-frameworks/knotifications-${KFMIN}:5
+ >=kde-frameworks/kwayland-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kwindowsystem-${KFMIN}:5
+ >=kde-frameworks/kxmlgui-${KFMIN}:5
+ >=kde-plasma/breeze-${PVCUT}:5
+ x11-libs/libXcursor
+ x11-libs/libxcb
+"
+RDEPEND="${DEPEND}
+ media-fonts/hack
+ media-fonts/noto
+"