summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-libs/rpcsvc-proto/Manifest1
-rw-r--r--net-libs/rpcsvc-proto/rpcsvc-proto-1.4.2.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/net-libs/rpcsvc-proto/Manifest b/net-libs/rpcsvc-proto/Manifest
index 8680cd917c8a..f85b701b1105 100644
--- a/net-libs/rpcsvc-proto/Manifest
+++ b/net-libs/rpcsvc-proto/Manifest
@@ -1 +1,2 @@
DIST rpcsvc-proto-1.4.1.tar.gz 61724 BLAKE2B 4fd04b36d30561edf3bbc9f565b07a8f1450ca28d7489b63d241f0b7eb2b98640d2dc2d798b1469460f682c0774fc99a995239d7e0fe2f244852b2561b37a0fb SHA512 a75546255bc5c553ec12dc0844783907b70499eb65ea6fb9de7c0a0f669e4ef0caa717c0cbe9ba8651dc7acfb0c9c4e0fc644ebf12e0a704819fa47e6c65b8b7
+DIST rpcsvc-proto-1.4.2.tar.gz 61788 BLAKE2B e941fa86088d690e3e80a501beb5169a51ff77b60d618f54db9d9fd5fb96c2b2a4277ab8d847dcdb29dadd2f6947d155b15cd8b6af1f1420e023da8637d555c0 SHA512 6769f9439e3f187eebdeef4ee8d54f8a6fee6f410e3137d0c1b26e61b705873932890856faff55b68c39aa702e456b36fe9410b85baf1ef9b20ee97f2158971a
diff --git a/net-libs/rpcsvc-proto/rpcsvc-proto-1.4.2.ebuild b/net-libs/rpcsvc-proto/rpcsvc-proto-1.4.2.ebuild
new file mode 100644
index 000000000000..d7df5d09a441
--- /dev/null
+++ b/net-libs/rpcsvc-proto/rpcsvc-proto-1.4.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="rpcsvc protocol definitions from glibc"
+HOMEPAGE="https://github.com/thkukuk/rpcsvc-proto"
+SRC_URI="https://github.com/thkukuk/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="LGPL-2.1+ BSD"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE=""
+
+# sys-devel/gettext is only for libintl detection macros.
+DEPEND="sys-devel/gettext"
+RDEPEND="
+ !<sys-libs/glibc-2.26
+ virtual/libintl
+"
+
+src_prepare() {
+ default
+ eautoreconf
+
+ # Use ${CHOST}-cpp, not 'cpp': bug #718138
+ # Ideally we should use @CPP@ but rpcgen makes it hard to use '${CHOST}-gcc -E'
+ sed -i -s "s/CPP = \"cpp\";/CPP = \"${CHOST}-cpp\";/" rpcgen/rpc_main.c || die
+}
+
+src_install() {
+ default
+
+ # provided by sys-fs/quota[rpc]
+ rm "${ED}"/usr/include/rpcsvc/rquota.{x,h} || die
+}