summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-crypt/sign/sign-1.0.7.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/app-crypt/sign/sign-1.0.7.ebuild b/app-crypt/sign/sign-1.0.7.ebuild
index 3277e9e9ba25..dd59e5d0f64f 100644
--- a/app-crypt/sign/sign-1.0.7.ebuild
+++ b/app-crypt/sign/sign-1.0.7.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=4
+EAPI=5
inherit toolchain-funcs eutils
@@ -13,9 +13,11 @@ SRC_URI="http://swapped.cc/${PN}/files/${P}.tar.gz"
LICENSE="BZIP2"
SLOT="0"
KEYWORDS="amd64 ppc x86 ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE=""
+IUSE="libressl"
-RDEPEND=">=dev-libs/openssl-0.9.8"
+RDEPEND="
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )"
DEPEND="${RDEPEND}"
src_prepare() {