summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-misc/gogoc/Manifest1
-rw-r--r--net-misc/gogoc/files/gogoc-1.2+gcc-4.6.patch26
-rw-r--r--net-misc/gogoc/files/gogoc-1.2-overflow.patch35
-rw-r--r--net-misc/gogoc/files/gogoc.rc42
-rw-r--r--net-misc/gogoc/files/gogoc.service12
-rw-r--r--net-misc/gogoc/gogoc-1.2-r2.ebuild96
-rw-r--r--net-misc/gogoc/gogoc-1.2-r3.ebuild97
-rw-r--r--net-misc/gogoc/metadata.xml14
-rw-r--r--profiles/package.mask5
9 files changed, 0 insertions, 328 deletions
diff --git a/net-misc/gogoc/Manifest b/net-misc/gogoc/Manifest
deleted file mode 100644
index 867480b894d9..000000000000
--- a/net-misc/gogoc/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST gogoc-1_2-RELEASE.tar.gz 249286 SHA256 a0ef45c0bd1fc9964dc8ac059b7d78c12674bf67ef641740554e166fa99a2f49 SHA512 4ca4de23f81d3c08b514514c6f29bba0eb7dc34dda0fb82de1721b87ab337db018a90808f412de0f38a85baa0808d6f27e6e08b42e120634ff7d483e16793829 WHIRLPOOL b6228e23e5b7aa4f33c84cafcf92218986379b275c7a1945eba0b667fcc810dda06bc5f73ea3e095f66cceb6211bb2f023b4e065f1b68633e557972381c57346
diff --git a/net-misc/gogoc/files/gogoc-1.2+gcc-4.6.patch b/net-misc/gogoc/files/gogoc-1.2+gcc-4.6.patch
deleted file mode 100644
index 94582d9dd018..000000000000
--- a/net-misc/gogoc/files/gogoc-1.2+gcc-4.6.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-Index: gogoc-1_2-RELEASE/gogoc-messaging/src/clientmsgsender.cc
-===================================================================
---- gogoc-1_2-RELEASE.orig/gogoc-messaging/src/clientmsgsender.cc
-+++ gogoc-1_2-RELEASE/gogoc-messaging/src/clientmsgsender.cc
-@@ -15,7 +15,7 @@
- // **************************************************************************
- #include <gogocmessaging/clientmsgsender.h>
- #include <assert.h>
--
-+#include <cstddef>
-
- namespace gogocmessaging
- {
-Index: gogoc-1_2-RELEASE/gogoc-messaging/src/servermsgsender.cc
-===================================================================
---- gogoc-1_2-RELEASE.orig/gogoc-messaging/src/servermsgsender.cc
-+++ gogoc-1_2-RELEASE/gogoc-messaging/src/servermsgsender.cc
-@@ -15,7 +15,7 @@
- // **************************************************************************
- #include <gogocmessaging/servermsgsender.h>
- #include <assert.h>
--
-+#include <cstddef>
-
- namespace gogocmessaging
- {
diff --git a/net-misc/gogoc/files/gogoc-1.2-overflow.patch b/net-misc/gogoc/files/gogoc-1.2-overflow.patch
deleted file mode 100644
index ddc414ce0e70..000000000000
--- a/net-misc/gogoc/files/gogoc-1.2-overflow.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-Index: gogoc-1_2-RELEASE/gogoc-config/src/gogocvalidation.cc
-===================================================================
---- gogoc-1_2-RELEASE.orig/gogoc-config/src/gogocvalidation.cc
-+++ gogoc-1_2-RELEASE/gogoc-config/src/gogocvalidation.cc
-@@ -512,7 +512,7 @@ bool Validate_ClientV4( const string& sC
- if( sClientV4 != STR_AUTO )
- {
- struct in_addr address;
-- unsigned long net;
-+ in_addr_t net;
-
- net = inet_addr( sClientV4.c_str() );
- memcpy(&address, &net, sizeof(net));
-@@ -535,7 +535,7 @@ bool Validate_DSLite( const string& sDSL
-
- {
- struct in_addr address;
-- unsigned long net;
-+ in_addr_t net;
-
- net = inet_addr( sDSLite.c_str() );
- memcpy(&address, &net, sizeof(net));
-Index: gogoc-1_2-RELEASE/gogoc-config/src/haccessdevicemappingconfig.cc
-===================================================================
---- gogoc-1_2-RELEASE.orig/gogoc-config/src/haccessdevicemappingconfig.cc
-+++ gogoc-1_2-RELEASE/gogoc-config/src/haccessdevicemappingconfig.cc
-@@ -265,7 +265,7 @@ bool HACCESSDeviceMappingConfig::Validat
- // Check if IPv4 or IPv6 address
- struct in6_addr addressv6;
- struct in_addr addressv4;
-- unsigned long net;
-+ in_addr_t net;
-
- net = inet_addr( aIPAddress.c_str() );
- memcpy(&addressv4, &net, sizeof(net));
diff --git a/net-misc/gogoc/files/gogoc.rc b/net-misc/gogoc/files/gogoc.rc
deleted file mode 100644
index bb639a1b18b6..000000000000
--- a/net-misc/gogoc/files/gogoc.rc
+++ /dev/null
@@ -1,42 +0,0 @@
-#!/sbin/openrc-run
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-depend() {
- need net localmount
- after bootmisc
- use dns logger
-}
-
-checktun() {
- [ $(uname -s) = "Linux" ] || return 0
- [ -e /dev/net/tun ] && return 0
- modprobe tun && return 0
-
- eerror "TUN/TAP support is not available in the running kernel"
- return 1
-}
-
-checkconfig() {
- if ! [ -f /etc/gogoc/gogoc.conf ]; then
- eerror "Unable to find configuration file /etc/gogoc/gogoc.conf"
- return 1
- fi
-}
-
-start() {
- checktun || return 1
- checkconfig || return 1
-
- ebegin "Starting gogoCLIENT"
- start-stop-daemon --start --exec /usr/sbin/gogoc \
- --chdir /var/lib/gogoc -- -f /etc/gogoc/gogoc.conf -y
- eend $?
-}
-
-stop() {
- ebegin "Stopping gogoCLIENT"
- start-stop-daemon --stop --exec /usr/sbin/gogoc
- eend $?
-}
diff --git a/net-misc/gogoc/files/gogoc.service b/net-misc/gogoc/files/gogoc.service
deleted file mode 100644
index fe7b31e9be97..000000000000
--- a/net-misc/gogoc/files/gogoc.service
+++ /dev/null
@@ -1,12 +0,0 @@
-[Unit]
-Description=Client to connect to a tunnel broker using the TSP protocol (freenet6 for example)
-
-[Service]
-ExecStart=/usr/sbin/gogoc -y -f /etc/gogoc/gogoc.conf
-ExecReload=/bin/kill -HUP $MAINPID
-KillMode=process
-Restart=always
-RestartSec=4
-
-[Install]
-WantedBy=multi-user.target
diff --git a/net-misc/gogoc/gogoc-1.2-r2.ebuild b/net-misc/gogoc/gogoc-1.2-r2.ebuild
deleted file mode 100644
index 650825d0fc41..000000000000
--- a/net-misc/gogoc/gogoc-1.2-r2.ebuild
+++ /dev/null
@@ -1,96 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=4
-
-inherit eutils versionator toolchain-funcs
-
-MY_P=${PN}-$(replace_all_version_separators "_")
-if [[ ${MY_P/_beta/} != ${MY_P} ]]; then
- MY_P=${MY_P/_beta/-BETA}
-else
- MY_P=${MY_P}-RELEASE
-fi
-
-DESCRIPTION="Client to connect to a tunnel broker using the TSP protocol (freenet6 for example)"
-HOMEPAGE="http://gogonet.gogo6.com/page/download-1"
-SRC_URI="http://gogo6.com/downloads/${MY_P}.tar.gz"
-
-# GPL-2 for Gentoo init script
-LICENSE="MIT GPL-2"
-SLOT="0"
-KEYWORDS="amd64 hppa sparc x86"
-IUSE="debug"
-
-DEPEND="dev-libs/openssl"
-RDEPEND="${DEPEND}
- sys-apps/iproute2
- >=sys-apps/net-tools-1.60_p20120127084908"
-
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-overflow.patch
- epatch "${FILESDIR}"/${P}+gcc-4.6.patch
-
- # Make the makefile handle linking correctly
- find . -name Makefile -exec sed -i \
- -e 's:LDFLAGS:LDLIBS:g' \
- -e '/\$(LDLIBS)/s:-o:$(LDFLAGS) -o:' \
- {} + || die "multised failed"
-
- sed -i -e 's:/usr/local/etc/gogoc:/etc/gogoc:' \
- gogoc-tsp/platform/*/tsp_local.c \
- || die "path sed failed"
-
- # Newer net-tools use /bin
- sed -i -e "/^\(route\|ifconfig\)=/s/sbin/bin/" \
- gogoc-tsp/template/linux.sh \
- || die "net-tools sed failed"
-}
-
-src_configure() { :; }
-
-src_compile() {
- # parallel make fails as inter-directory dependecies are missing.
- emake -j1 \
- AR="$(tc-getAR)" RANLIB="$(tc-getRANLIB)" \
- CC="$(tc-getCC)" CXX="$(tc-getCXX)" LD="$(tc-getCXX)" \
- EXTRA_CFLAGS="${CFLAGS}" EXTRA_CXXFLAGS="${CXXFLAGS}" \
- $(use debug && echo DEBUG=1) \
- all target=linux
-
- emake -C gogoc-tsp/conf \
- PLATFORM=linux PLATFORM_DIR=../platform BIN_DIR=../bin \
- gogoc.conf.sample
-}
-
-src_install() {
- dodoc README
-
- cd "${S}"/gogoc-tsp
- dosbin bin/gogoc
-
- dodoc bin/gogoc.conf.sample
-
- exeinto /etc/gogoc/template
- doexe template/linux.sh
-
- newinitd "${FILESDIR}"/gogoc.rc gogoc
-
- doman man/{man5/gogoc.conf.5,man8/gogoc.8}
- keepdir /var/lib/gogoc
-
- diropts -m0700
- keepdir /etc/gogoc
-}
-
-pkg_postinst() {
- elog "You should create an /etc/gogoc/gogoc.conf file starting from"
- elog "the sample configuration in /usr/share/doc/${PF}/gogoc.conf.sample.*"
- elog ""
- elog "To add support for a TSP IPv6 connection at startup,"
- elog "remember to run:"
- elog "# rc-update add gogoc default"
-}
diff --git a/net-misc/gogoc/gogoc-1.2-r3.ebuild b/net-misc/gogoc/gogoc-1.2-r3.ebuild
deleted file mode 100644
index b0c3eb9dfd47..000000000000
--- a/net-misc/gogoc/gogoc-1.2-r3.ebuild
+++ /dev/null
@@ -1,97 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=4
-
-inherit eutils systemd versionator toolchain-funcs
-
-MY_P=${PN}-$(replace_all_version_separators "_")
-if [[ ${MY_P/_beta/} != ${MY_P} ]]; then
- MY_P=${MY_P/_beta/-BETA}
-else
- MY_P=${MY_P}-RELEASE
-fi
-
-DESCRIPTION="Client to connect to a tunnel broker using the TSP protocol (freenet6 for example)"
-HOMEPAGE="http://gogonet.gogo6.com/page/download-1"
-SRC_URI="http://gogo6.com/downloads/${MY_P}.tar.gz"
-
-# GPL-2 for Gentoo init script
-LICENSE="MIT GPL-2"
-SLOT="0"
-KEYWORDS="amd64 hppa sparc x86"
-IUSE="debug"
-
-DEPEND="dev-libs/openssl"
-RDEPEND="${DEPEND}
- sys-apps/iproute2
- >=sys-apps/net-tools-1.60_p20120127084908"
-
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-overflow.patch
- epatch "${FILESDIR}"/${P}+gcc-4.6.patch
-
- # Make the makefile handle linking correctly
- find . -name Makefile -exec sed -i \
- -e 's:LDFLAGS:LDLIBS:g' \
- -e '/\$(LDLIBS)/s:-o:$(LDFLAGS) -o:' \
- {} + || die "multised failed"
-
- sed -i -e 's:/usr/local/etc/gogoc:/etc/gogoc:' \
- gogoc-tsp/platform/*/tsp_local.c \
- || die "path sed failed"
-
- # Newer net-tools use /bin
- sed -i -e "/^\(route\|ifconfig\)=/s/sbin/bin/" \
- gogoc-tsp/template/linux.sh \
- || die "net-tools sed failed"
-}
-
-src_configure() { :; }
-
-src_compile() {
- # parallel make fails as inter-directory dependecies are missing.
- emake -j1 \
- AR="$(tc-getAR)" RANLIB="$(tc-getRANLIB)" \
- CC="$(tc-getCC)" CXX="$(tc-getCXX)" LD="$(tc-getCXX)" \
- EXTRA_CFLAGS="${CFLAGS}" EXTRA_CXXFLAGS="${CXXFLAGS}" \
- $(use debug && echo DEBUG=1) \
- all target=linux
-
- emake -C gogoc-tsp/conf \
- PLATFORM=linux PLATFORM_DIR=../platform BIN_DIR=../bin \
- gogoc.conf.sample
-}
-
-src_install() {
- dodoc README
-
- cd "${S}"/gogoc-tsp
- dosbin bin/gogoc
-
- dodoc bin/gogoc.conf.sample
-
- exeinto /etc/gogoc/template
- doexe template/linux.sh
-
- newinitd "${FILESDIR}"/gogoc.rc gogoc
- systemd_dounit "${FILESDIR}"/${PN}.service
-
- doman man/{man5/gogoc.conf.5,man8/gogoc.8}
- keepdir /var/lib/gogoc
-
- diropts -m0700
- keepdir /etc/gogoc
-}
-
-pkg_postinst() {
- elog "You should create an /etc/gogoc/gogoc.conf file starting from"
- elog "the sample configuration in /usr/share/doc/${PF}/gogoc.conf.sample.*"
- elog ""
- elog "To add support for a TSP IPv6 connection at startup,"
- elog "remember to run:"
- elog "# rc-update add gogoc default"
-}
diff --git a/net-misc/gogoc/metadata.xml b/net-misc/gogoc/metadata.xml
deleted file mode 100644
index 18e3b6b2dedc..000000000000
--- a/net-misc/gogoc/metadata.xml
+++ /dev/null
@@ -1,14 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>voyageur@gentoo.org</email>
- <name>Bernard Cafarelli</name>
- </maintainer>
- <longdescription>
- TSP is a control protocol used to establish and maintain static tunnels. gogoCLIENT is
- used on the host computer to connect to a tunnel broker using the TSP protocol and to get the
- information for its tunnel. When it receives the information for the tunnel, gogoCLIENT
- creates the static tunnel on its operating system
-</longdescription>
-</pkgmetadata>
diff --git a/profiles/package.mask b/profiles/package.mask
index 0a2b35d01bb6..bcdf73b174aa 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -646,11 +646,6 @@ dev-perl/Test-Tester
# recent JVMs. Masked for removal in 30 days. See bug #584562.
dev-java/oscache
-# Bernard Cafarelli <voyageur@gentoo.org> (26 Jul 2016)
-# Upstream closed service. Switch to another IPv6 tunnel broker
-# Masked for removal in 30 days, bug #589760
-net-misc/gogoc
-
# Michał Górny <mgorny@gentoo.org> (18 Jul 2016)
# Pre-release of a complete rewrite, provided for early testing. Not all
# functionality is provided yet. Use --pretend to make sure correct