summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-fs/mdadm/files/mdadm-3.4-sysmacros.patch31
-rw-r--r--sys-fs/mdadm/mdadm-3.4.ebuild4
2 files changed, 35 insertions, 0 deletions
diff --git a/sys-fs/mdadm/files/mdadm-3.4-sysmacros.patch b/sys-fs/mdadm/files/mdadm-3.4-sysmacros.patch
new file mode 100644
index 000000000000..22a393447632
--- /dev/null
+++ b/sys-fs/mdadm/files/mdadm-3.4-sysmacros.patch
@@ -0,0 +1,31 @@
+https://bugs.gentoo.org/580188
+
+From 5c97e465b33bf8fefb17da7f553a1c3812e508d5 Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Tue, 19 Apr 2016 18:10:54 -0400
+Subject: [PATCH] include sys/sysmacros.h for major/minor/makedev prototypes
+
+These funcs are defined in sys/sysmacros.h, so include it for them.
+It works today due to an implicit include by sys/types.h, but the
+various Linux C libraries are moving away from that.
+
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+---
+ mdadm.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/mdadm.h b/mdadm.h
+index d209488..b8767a7 100755
+--- a/mdadm.h
++++ b/mdadm.h
+@@ -33,6 +33,7 @@ extern __off64_t lseek64 __P ((int __fd, __off64_t __offset, int __whence));
+ # endif
+ #endif
+
++#include <sys/sysmacros.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <stdint.h>
+--
+2.7.4
+
diff --git a/sys-fs/mdadm/mdadm-3.4.ebuild b/sys-fs/mdadm/mdadm-3.4.ebuild
index a4aff3eb858e..559b74e5ad9b 100644
--- a/sys-fs/mdadm/mdadm-3.4.ebuild
+++ b/sys-fs/mdadm/mdadm-3.4.ebuild
@@ -24,6 +24,10 @@ RDEPEND=">=sys-apps/util-linux-2.16"
# Thus, they shouldn't be run on systems with active software RAID devices.
RESTRICT="test"
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-3.4-sysmacros.patch #580188
+}
+
mdadm_emake() {
# We should probably make corosync & libdlm into USE flags. #573782
emake \