summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/gsd/gsd-1.5.3-r1.ebuild (renamed from dev-python/gsd/gsd-1.5.3.ebuild)8
1 files changed, 5 insertions, 3 deletions
diff --git a/dev-python/gsd/gsd-1.5.3.ebuild b/dev-python/gsd/gsd-1.5.3-r1.ebuild
index 3296d63c7ea5..caac808feb22 100644
--- a/dev-python/gsd/gsd-1.5.3.ebuild
+++ b/dev-python/gsd/gsd-1.5.3-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{5,6} )
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
inherit distutils-r1
DESCRIPTION="GSD - file format specification and a library to read and write it"
@@ -15,7 +15,9 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-DEPEND="
+RDEPEND="
dev-python/numpy[${PYTHON_USEDEP}]"
+BDEPEND="
+ ${RDEPEND}"
S="${WORKDIR}/${PN}-v${PV}"