summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-apps/hdparm/files/hdparm-9.50-build.patch32
-rw-r--r--sys-apps/hdparm/hdparm-9.50.ebuild10
2 files changed, 36 insertions, 6 deletions
diff --git a/sys-apps/hdparm/files/hdparm-9.50-build.patch b/sys-apps/hdparm/files/hdparm-9.50-build.patch
new file mode 100644
index 000000000000..ff1948acb01e
--- /dev/null
+++ b/sys-apps/hdparm/files/hdparm-9.50-build.patch
@@ -0,0 +1,32 @@
+* drop hardcoded -O2 flag from CFLAGS
+* drop hardcoded -s (strip) flag from LDFLAGS, and respect user LDFLAGS
+* fix hardcoded `make` and hardcoded -j2 flags
+* respect CFLAGS when linking
+
+--- a/Makefile
++++ b/Makefile
+@@ -13,9 +13,8 @@
+ CC ?= gcc
+ STRIP ?= strip
+
+-CFLAGS := -O2 -W -Wall -Wbad-function-cast -Wcast-align -Wpointer-arith -Wcast-qual -Wshadow -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -fkeep-inline-functions -Wwrite-strings -Waggregate-return -Wnested-externs -Wtrigraphs $(CFLAGS)
++CFLAGS += -W -Wall -Wbad-function-cast -Wcast-align -Wpointer-arith -Wcast-qual -Wshadow -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -fkeep-inline-functions -Wwrite-strings -Waggregate-return -Wnested-externs -Wtrigraphs
+
+-LDFLAGS = -s
+ #LDFLAGS = -s -static
+ INSTALL = install
+ INSTALL_DATA = $(INSTALL) -m 644
+@@ -24,11 +23,10 @@ INSTALL_PROGRAM = $(INSTALL)
+
+ OBJS = hdparm.o identify.o sgio.o sysfs.o geom.o fallocate.o fibmap.o fwdownload.o dvdspeed.o wdidle3.o
+
+-all:
+- make -j2 hdparm
++all: hdparm
+
+ hdparm: hdparm.h sgio.h $(OBJS)
+- $(CC) $(LDFLAGS) -o hdparm $(OBJS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o hdparm $(OBJS)
+ $(STRIP) hdparm
+
+ hdparm.o: hdparm.h sgio.h
diff --git a/sys-apps/hdparm/hdparm-9.50.ebuild b/sys-apps/hdparm/hdparm-9.50.ebuild
index 4db68894082f..f447ca477993 100644
--- a/sys-apps/hdparm/hdparm-9.50.ebuild
+++ b/sys-apps/hdparm/hdparm-9.50.ebuild
@@ -17,15 +17,13 @@ IUSE="static"
src_prepare() {
epatch "${FILESDIR}"/${PN}-9.48-sysmacros.patch #580052
+ epatch "${FILESDIR}"/${PN}-9.50-build.patch
use static && append-ldflags -static
- sed -i \
- -e "/^CFLAGS/ s:-O2:${CFLAGS}:" \
- -e "/^LDFLAGS/ s:-s:${LDFLAGS}:" \
- Makefile || die "sed"
}
-src_compile() {
- emake STRIP=: CC="$(tc-getCC)"
+src_configure() {
+ tc-export CC
+ export STRIP=:
}
src_install() {