summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-themes/papirus-icon-theme/Manifest1
-rw-r--r--x11-themes/papirus-icon-theme/metadata.xml11
-rw-r--r--x11-themes/papirus-icon-theme/papirus-icon-theme-20191009.ebuild26
3 files changed, 38 insertions, 0 deletions
diff --git a/x11-themes/papirus-icon-theme/Manifest b/x11-themes/papirus-icon-theme/Manifest
new file mode 100644
index 000000000000..db4b1cd72803
--- /dev/null
+++ b/x11-themes/papirus-icon-theme/Manifest
@@ -0,0 +1 @@
+DIST papirus-icon-theme-20191009.tar.gz 18636796 BLAKE2B cb1797468ffb1542fb6b732a0e54cf18b4158bf15ee0fd7f2c7616cba8568876bdfff0247fc1f311d15f064836d7a17916ac14887c3f4132983ebc7e75736668 SHA512 09d259783439721baf68bb5c65cc9cb51af148356e8c8c277ba2f45b5c96358f14defe1bb34db0281cb0cf77023ab54017e0d348de2910648a918a1638ae334f
diff --git a/x11-themes/papirus-icon-theme/metadata.xml b/x11-themes/papirus-icon-theme/metadata.xml
new file mode 100644
index 000000000000..cf5de6be3f61
--- /dev/null
+++ b/x11-themes/papirus-icon-theme/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+ <email>zlogene@gentoo.org</email>
+ <name>Mikle Kolyada</name>
+</maintainer>
+<upstream>
+ <remote-id type="github">PapirusDevelopmentTeam/papirus-icon-theme</remote-id>
+</upstream>
+</pkgmetadata>
diff --git a/x11-themes/papirus-icon-theme/papirus-icon-theme-20191009.ebuild b/x11-themes/papirus-icon-theme/papirus-icon-theme-20191009.ebuild
new file mode 100644
index 000000000000..8afbb557b0ce
--- /dev/null
+++ b/x11-themes/papirus-icon-theme/papirus-icon-theme-20191009.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome2-utils
+
+DESCRIPTION="icon theme for Linux"
+HOMEPAGE="https://github.com/PapirusDevelopmentTeam/papirus-icon-theme"
+SRC_URI="https://github.com/PapirusDevelopmentTeam/papirus-icon-theme/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_compile() { :; }
+
+src_install() {
+ insinto /usr/share/icons
+ doins -r ePapirus Papirus{,-Dark,-Light}
+
+}
+
+pkg_preinst() { gnome2_icon_savelist; }
+pkg_postinst() { gnome2_icon_cache_update; }
+pkg_postrm() { gnome2_icon_cache_update; }