summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/libdynd/Manifest2
-rw-r--r--dev-libs/libdynd/files/libdynd-0.6.0-dont-install-test.patch15
-rw-r--r--dev-libs/libdynd/libdynd-0.6.5.ebuild66
-rw-r--r--dev-libs/libdynd/libdynd-0.6.6.ebuild66
4 files changed, 0 insertions, 149 deletions
diff --git a/dev-libs/libdynd/Manifest b/dev-libs/libdynd/Manifest
index 772aafd8b65a..52b060d4afbe 100644
--- a/dev-libs/libdynd/Manifest
+++ b/dev-libs/libdynd/Manifest
@@ -1,3 +1 @@
-DIST libdynd-0.6.5.tar.gz 1238404 BLAKE2B be3b1c921c1d8b4d8cdc7d70ef908fea5d38f97743db9db8f4b8716ee58d633f3040c727eb0b9287701d751ea8929b78f1e5f07e7d3b9900630594ec3d81444e SHA512 ebf64b94b38300e4e471f975a51e4b014879937e855af5d72a3f759af4445fa9024e42962ab1284ebe7b2ae2ddf51ea418d106c9894e1841f0984622afbef115
-DIST libdynd-0.6.6.tar.gz 1261349 BLAKE2B 73c9eba440dfa71cd8403ecfe4c77bb1ec19530333bea8689e9d8cd8863da6a37718af878f4ab5ca278631e0acf67035df4bc00ec4e3360c4558c0184e1f33e9 SHA512 efeb52a5b5dd3154ca293f388d5b967ff983450253435572b919f7c4a1445ad3cb416def4c736f908fdb3b06cddebae881a58420e528f1ca145973a997af7a28
DIST libdynd-0.7.2.tar.gz 1342364 BLAKE2B 28617a6b01c09dd8030d376f73c6dc6ddb4cd031aaa59348283fbb1226bb401e2d7ab48385263b8abc4ca95ffd75d2ce9f3b52a417fe04c6597886f8626cdd3f SHA512 134195ba5839e05af07dd9ad0b8e749a83345511acd2a22a029a4d9a2c0fc77a8a1f36722bce20653d28189b7883afe7feb651c7d32ff921ef257a8a9aa4bd7f
diff --git a/dev-libs/libdynd/files/libdynd-0.6.0-dont-install-test.patch b/dev-libs/libdynd/files/libdynd-0.6.0-dont-install-test.patch
deleted file mode 100644
index 9659372b05ea..000000000000
--- a/dev-libs/libdynd/files/libdynd-0.6.0-dont-install-test.patch
+++ /dev/null
@@ -1,15 +0,0 @@
---- tests/CMakeLists.txt.orig 2014-02-10 14:25:18.041841087 -0800
-+++ tests/CMakeLists.txt 2014-02-10 14:25:40.224975614 -0800
-@@ -105,12 +105,6 @@
- )
- endif()
-
--# If installation is requested, install the program
--if (DYND_INSTALL_LIB)
-- install(TARGETS test_libdynd
-- RUNTIME DESTINATION bin)
--endif()
--
- # Compile-time tests: test code that is supposed to produce compile errors
- # I couldn't find a properly specified way to do this, so hacked together
- # this function.
diff --git a/dev-libs/libdynd/libdynd-0.6.5.ebuild b/dev-libs/libdynd/libdynd-0.6.5.ebuild
deleted file mode 100644
index 9eb37ce666ac..000000000000
--- a/dev-libs/libdynd/libdynd-0.6.5.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit cmake-utils multilib cuda
-
-# change each release, to avoid git in tree dependency
-DYND_GIT_SHA1=2e140844d4a21c436ca0fc46996bf8606ffc21d5
-
-DESCRIPTION="C++ dynamic multi-dimensionnal array library with Python exposure"
-HOMEPAGE="https://github.com/ContinuumIO/libdynd"
-SRC_URI="https://github.com/ContinuumIO/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-IUSE="cuda doc fftw test"
-
-RDEPEND="
- dev-libs/c-blosc:0=
- cuda? ( x11-drivers/nvidia-drivers dev-util/nvidia-cuda-toolkit )
- fftw? ( sci-libs/fftw:3.0 )
- "
-DEPEND="${RDEPEND}"
-
-DOCS=( README.md )
-
-PATCHES=(
- "${FILESDIR}"/${PN}-0.6.0-dont-install-test.patch
-)
-
-src_prepare() {
- cmake-utils_src_prepare
- # each relase comes with a different set...
- # remove forced strong flags
- sed -i \
- -e "s|@DYND_GIT_SHA1@|${DYND_GIT_SHA1}|" \
- -e "s|@DYND_VERSION@|${PV}|" \
- -e 's|-fomit-frame-pointer||' \
- -e 's|-Werror||g' \
- CMakeLists.txt || die
-}
-
-src_configure() {
- sed -i \
- -e '/add_subdirectory(examples)/d' \
- CMakeLists.txt || die
- local mycmakeargs=(
- -DDYND_SHARED_LIB=ON
- -DDYND_INSTALL_LIB=ON
- $(cmake-utils_use cuda DYND_CUDA)
- $(cmake-utils_use test DYND_BUILD_TESTS)
- )
- cmake-utils_src_configure
-}
-
-src_test() {
- cd "${BUILD_DIR}" || die
- ./tests/test_libdynd || die
-}
-
-src_install() {
- cmake-utils_src_install
- use doc && dodoc documents/*
-}
diff --git a/dev-libs/libdynd/libdynd-0.6.6.ebuild b/dev-libs/libdynd/libdynd-0.6.6.ebuild
deleted file mode 100644
index a122f6f30306..000000000000
--- a/dev-libs/libdynd/libdynd-0.6.6.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit cmake-utils multilib cuda
-
-# change each release, to avoid git in tree dependency
-DYND_GIT_SHA1=09fb7e5eccadbe1ec49ff4b05fec724939331e6d
-
-DESCRIPTION="C++ dynamic multi-dimensionnal array library with Python exposure"
-HOMEPAGE="https://github.com/ContinuumIO/libdynd"
-SRC_URI="https://github.com/ContinuumIO/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="cuda doc fftw test"
-
-RDEPEND="
- dev-libs/c-blosc:0=
- cuda? ( x11-drivers/nvidia-drivers dev-util/nvidia-cuda-toolkit )
- fftw? ( sci-libs/fftw:3.0 )
- "
-DEPEND="${RDEPEND}"
-
-DOCS=( README.md )
-
-PATCHES=(
- "${FILESDIR}"/${PN}-0.6.0-dont-install-test.patch
-)
-
-src_prepare() {
- cmake-utils_src_prepare
- # each relase comes with a different set...
- # remove forced strong flags
- sed -i \
- -e "s|@DYND_GIT_SHA1@|${DYND_GIT_SHA1}|" \
- -e "s|@DYND_VERSION@|${PV}|" \
- -e 's|-fomit-frame-pointer||' \
- -e 's|-Werror||g' \
- CMakeLists.txt || die
-}
-
-src_configure() {
- sed -i \
- -e '/add_subdirectory(examples)/d' \
- CMakeLists.txt || die
- local mycmakeargs=(
- -DDYND_SHARED_LIB=ON
- -DDYND_INSTALL_LIB=ON
- $(cmake-utils_use cuda DYND_CUDA)
- $(cmake-utils_use test DYND_BUILD_TESTS)
- )
- cmake-utils_src_configure
-}
-
-src_test() {
- cd "${BUILD_DIR}" || die
- ./tests/test_libdynd || die
-}
-
-src_install() {
- cmake-utils_src_install
- use doc && dodoc documents/*
-}