summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--kde-misc/plasma-applet-weather-widget/Manifest1
-rw-r--r--kde-misc/plasma-applet-weather-widget/metadata.xml11
-rw-r--r--kde-misc/plasma-applet-weather-widget/plasma-applet-weather-widget-1.6.7.ebuild29
3 files changed, 41 insertions, 0 deletions
diff --git a/kde-misc/plasma-applet-weather-widget/Manifest b/kde-misc/plasma-applet-weather-widget/Manifest
new file mode 100644
index 000000000000..fd0751b46ba1
--- /dev/null
+++ b/kde-misc/plasma-applet-weather-widget/Manifest
@@ -0,0 +1 @@
+DIST plasma-applet-weather-widget-1.6.7.tar.gz 98864 SHA256 2f75b96c713ab2be65af6daa860b8df6c8116a7d54055f51a29e4425171237a7 SHA512 24da3014c652a8c8c39de89d61d33a9d745bb172a7ae7c71ca1a20fb834636d277e839f7d3205bd7349d9bc29c84f05bfb3c3f70c943be65f7acfe2315ce078e WHIRLPOOL 720df748c802b2f606944f15b977c85d0c88f975f3d9dd695a1042ccbae33a9db2b881da535bb2e05e043f5a982ba07488fcfe6eb94e3c75735a8b012bf4b006
diff --git a/kde-misc/plasma-applet-weather-widget/metadata.xml b/kde-misc/plasma-applet-weather-widget/metadata.xml
new file mode 100644
index 000000000000..707c75bcce5f
--- /dev/null
+++ b/kde-misc/plasma-applet-weather-widget/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>kde@gentoo.org</email>
+ <name>Gentoo KDE Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">kotelnik/plasma-applet-weather-widget</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/kde-misc/plasma-applet-weather-widget/plasma-applet-weather-widget-1.6.7.ebuild b/kde-misc/plasma-applet-weather-widget/plasma-applet-weather-widget-1.6.7.ebuild
new file mode 100644
index 000000000000..06e4ceebce32
--- /dev/null
+++ b/kde-misc/plasma-applet-weather-widget/plasma-applet-weather-widget-1.6.7.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit kde5
+
+DESCRIPTION="Plasma 5 applet for weather forecasts"
+HOMEPAGE="http://kde-look.org/content/show.php/Weather+Widget?content=169572
+https://github.com/kotelnik/plasma-applet-weather-widget"
+
+if [[ ${KDE_BUILD_TYPE} = live ]] ; then
+ EGIT_REPO_URI="https://github.com/kotelnik/${PN}.git"
+else
+ SRC_URI="https://github.com/kotelnik/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+LICENSE="GPL-2+"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep plasma)
+ $(add_qt_dep qtdeclarative)
+"
+RDEPEND="${DEPEND}"
+
+DOCS=( README.md )