summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-php/phpDocumentor/phpDocumentor-2.7.0.ebuild29
1 files changed, 21 insertions, 8 deletions
diff --git a/dev-php/phpDocumentor/phpDocumentor-2.7.0.ebuild b/dev-php/phpDocumentor/phpDocumentor-2.7.0.ebuild
index d86ffa0d17f1..5ce8467627e6 100644
--- a/dev-php/phpDocumentor/phpDocumentor-2.7.0.ebuild
+++ b/dev-php/phpDocumentor/phpDocumentor-2.7.0.ebuild
@@ -1,14 +1,15 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
-PHP_PEAR_URI="pear.phpdoc.org"
+PHP_PEAR_DOMAIN="pear.phpdoc.org"
+PHP_PEAR_CHANNEL="${FILESDIR}/channel.xml"
-inherit php-pear-r1
+inherit php-pear-r2
DESCRIPTION="The phpDocumentor package provides automatic documenting of php api directly from the source"
-
+SRC_URI="http://${PHP_PEAR_URI}/get/${PEAR_P}.tgz"
LICENSE="MIT"
SLOT="0"
@@ -18,11 +19,23 @@ IUSE="doc"
# block old version that provides the same binary
DEPEND="!dev-php/PEAR-PhpDocumentor"
RDEPEND="media-gfx/graphviz
- dev-lang/php[iconv,intl,xmlreader,xslt]"
+ dev-lang/php:*[iconv,intl,xmlreader,xslt]"
-src_install() {
- php-pear-r1_src_install
+src_prepare() {
+ sed -i -e "s~@php_dir@~${EPREFIX}/usr/share/php~" \
+ "${S}/bin/phpdoc" || die
+ eapply_user
+}
+src_install() {
+ exeinto /usr/bin
+ doexe bin/phpdoc
+ insinto /usr/share/php/${PN}
+ doins -r vendor src/* phpdoc.dist.xml bin/phpdoc.php
+ insinto /usr/share/php/data/${PN}
+ doins -r ansible data features box.json composer.json composer.lock phpmd.xml.dist wercker.yml
# install manual, tutorial, reference material
use doc && dodoc -r docs/*
+ php-pear-r2_install_packagexml
+ einstalldocs
}