summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-php/PEAR-Crypt_GPG/Manifest2
-rw-r--r--dev-php/PEAR-Crypt_GPG/PEAR-Crypt_GPG-1.6.0_beta1.ebuild18
-rw-r--r--dev-php/PEAR-Crypt_GPG/PEAR-Crypt_GPG-1.6.0_beta3.ebuild49
-rw-r--r--dev-php/PEAR-Crypt_GPG/metadata.xml11
4 files changed, 57 insertions, 23 deletions
diff --git a/dev-php/PEAR-Crypt_GPG/Manifest b/dev-php/PEAR-Crypt_GPG/Manifest
index e8efb77de0a2..292e0574fc2e 100644
--- a/dev-php/PEAR-Crypt_GPG/Manifest
+++ b/dev-php/PEAR-Crypt_GPG/Manifest
@@ -1,3 +1,3 @@
DIST Crypt_GPG-1.3.2.tgz 339001 SHA256 67f77bfb9b21dd428587f5bd336e4b9b2e200a1b62160e7ae0d0dfffd1357899 SHA512 c045942798f2974d1d200413864708b4476b53d1999b721f1b51fd6cfafb23c05479a391ebc7ebe513f5a88641d63d991e7ba59b7edcbd8397efde365528f999 WHIRLPOOL 27124bb96e28d7206f56e0d0fcbee603b3f1516a4d61a98e4a72139cae7e76b357f025bde04baec83530ff4ad6ec2a7d35d92a114ad9269ff198c06c94d63aef
DIST Crypt_GPG-1.4.2.tgz 345962 SHA256 8e1cf98b5bf37fead50745327261c021efac8c1ee2bddd57c38be57e8f1bc969 SHA512 c0384f0b4a35f8e7d7189b0b08c277c2629e7fa84e13f2c8c92aaafbeace7a60b6e18f2347571e7bcdf4bc504fd9463f080d9c2938063fdfcabc8f44dd7f4950 WHIRLPOOL ea6e2d0dfbfc56cf4bec5bcdfa312a5f43109c305b699b501e102e81908ad1ba350a97525b5d9ada45d6713ef64512744b6e04f208b5dc2f029ad01fedbffb4e
-DIST Crypt_GPG-1.6.0b1.tgz 344406 SHA256 a69ba79b8e5a75b3b4635045d9af1c83080b5224a1cf34b642aa86e8c50ec851 SHA512 2ac367edf13fdcccd4c279958fd414ae36cf2cebcc03fe5d561d9c918da7ef663d756c150287c96b5f7316609b1bd744d314c806dd47c7c8c25711d9e4076d29 WHIRLPOOL 851b79c95cc55ec07098b605d739ee78c9d0c14dbb6056baa8b57cdf9b773ea635e47185a80229bfdf96da88d179d7e3462960bf9d995f606727fab3a42ddf82
+DIST Crypt_GPG-1.6.0b3.tgz 345445 SHA256 fc3757b33a1ea39f9816521aca50dee4bf6c07cc9c7be60600db32066cf89d29 SHA512 0a3cb665fac8e84a0699600155cb74e2394e4759fe0b111d971d253ca511a371d06d826e54abadfbb3f707833cd3d6b369f52d04541b3e04f217056ec8439f4c WHIRLPOOL 0df9a3b21bbfc0d2f8e3cd8efaf8e19a58981520976faf1c4b501a363bbb05c2e4299de22e3c987f8f5ead36e98b5401c813d07947e4e84c6c664c2d46c4e3fa
diff --git a/dev-php/PEAR-Crypt_GPG/PEAR-Crypt_GPG-1.6.0_beta1.ebuild b/dev-php/PEAR-Crypt_GPG/PEAR-Crypt_GPG-1.6.0_beta1.ebuild
deleted file mode 100644
index b5ac7778a17a..000000000000
--- a/dev-php/PEAR-Crypt_GPG/PEAR-Crypt_GPG-1.6.0_beta1.ebuild
+++ /dev/null
@@ -1,18 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="6"
-
-inherit php-pear-r1
-
-DESCRIPTION="GNU Privacy Guard (GnuPG)"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE=""
-DEPEND=">=dev-lang/php-5.4.8:*[posix,unicode]"
-RDEPEND="${DEPEND}
- app-crypt/gnupg
- dev-php/PEAR-Console_CommandLine"
diff --git a/dev-php/PEAR-Crypt_GPG/PEAR-Crypt_GPG-1.6.0_beta3.ebuild b/dev-php/PEAR-Crypt_GPG/PEAR-Crypt_GPG-1.6.0_beta3.ebuild
new file mode 100644
index 000000000000..f4f3090e4b51
--- /dev/null
+++ b/dev-php/PEAR-Crypt_GPG/PEAR-Crypt_GPG-1.6.0_beta3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+MY_PN="${PN/PEAR-/}"
+MY_PV="${PV/_/}"
+MY_PV="${MY_PV/beta/b}"
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="PHP interface to the GNU Privacy Guard (GnuPG)"
+HOMEPAGE="http://pear.php.net/package/${MY_PN}"
+SRC_URI="http://download.pear.php.net/package/${MY_P}.tgz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="test"
+
+# Really only needs PEAR_Exception, not PEAR-PEAR.
+RDEPEND="app-crypt/gnupg
+ dev-lang/php:*[posix,unicode]
+ dev-php/PEAR-Console_CommandLine
+ dev-php/PEAR-PEAR"
+DEPEND="test? ( ${RDEPEND} dev-php/phpunit )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+ sed -i "s|@bin-dir@|${EPREFIX}/usr/bin|" Crypt/GPG/Engine.php || die
+ sed -i "s|@package-name@|${MY_PN}|" Crypt/GPG/PinEntry.php || die
+ sed -i "s|@data-dir@|${EPREFIX}/usr/share|" Crypt/GPG/PinEntry.php || die
+}
+
+src_install() {
+ dodoc README.md
+ dobin scripts/crypt-gpg-pinentry
+
+ insinto "/usr/share/${MY_PN}"
+ doins -r data
+
+ insinto /usr/share/php
+ doins -r Crypt
+}
+
+src_test() {
+ phpunit tests/ || die "test suite failed"
+}
diff --git a/dev-php/PEAR-Crypt_GPG/metadata.xml b/dev-php/PEAR-Crypt_GPG/metadata.xml
index b86acf66c756..b72578796195 100644
--- a/dev-php/PEAR-Crypt_GPG/metadata.xml
+++ b/dev-php/PEAR-Crypt_GPG/metadata.xml
@@ -1,8 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="project">
- <email>php-bugs@gentoo.org</email>
- <name>PHP</name>
- </maintainer>
+ <maintainer type="project">
+ <email>php-bugs@gentoo.org</email>
+ <name>PHP</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">pear/Crypt_GPG</remote-id>
+ </upstream>
</pkgmetadata>