summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/filelock/Manifest1
-rw-r--r--dev-python/filelock/filelock-3.7.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/filelock/Manifest b/dev-python/filelock/Manifest
index 9d0b6d61eed2..818610c1dd53 100644
--- a/dev-python/filelock/Manifest
+++ b/dev-python/filelock/Manifest
@@ -1 +1,2 @@
DIST py-filelock-3.6.0.tar.gz 204238 BLAKE2B f65a6e8ca8645dbeaf5ebbad00a8001cd88065da997097ef2ce74b5eee4dabfaf44d53a240498e82905589943f045422b44776c3b8de3077656a3b9612396156 SHA512 f55ad90d79e90eb5a915afffecc632566456604a62b89fb13304c5812e05a34c508c863e76246a254acd98f55930d3179b0908a06d1e5a203d578a826a048ae2
+DIST py-filelock-3.7.0.tar.gz 204366 BLAKE2B 9ef0a488603a5d210a232e472d2bcdce7f867b7b3fdb8dbe167dde54cd8c7085561f09d5a746ad7565ae7853495bd84c0b14cfa136a9d466f18f037ea0b9e8d1 SHA512 1b01a25a1ec194be1727a7245d6bada3a5f6e38bc16c0c78793ec0cf3dcdee6cc6b5c04fc74ae3687afd354379c73e189f7f3a8964853b8533a489ed2a0c6a04
diff --git a/dev-python/filelock/filelock-3.7.0.ebuild b/dev-python/filelock/filelock-3.7.0.ebuild
new file mode 100644
index 000000000000..7a2524fc927f
--- /dev/null
+++ b/dev-python/filelock/filelock-3.7.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2018-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+MY_P=py-filelock-${PV}
+DESCRIPTION="A platform independent file lock for Python"
+HOMEPAGE="
+ https://github.com/tox-dev/py-filelock/
+ https://pypi.org/project/filelock/
+"
+SRC_URI="
+ https://github.com/tox-dev/py-filelock/archive/${PV}.tar.gz
+ -> ${MY_P}.tar.gz
+"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}