summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-editors/mousepad/Manifest1
-rw-r--r--app-editors/mousepad/mousepad-0.6.0.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/app-editors/mousepad/Manifest b/app-editors/mousepad/Manifest
index 4c6d73e70673..2f1911a0a97b 100644
--- a/app-editors/mousepad/Manifest
+++ b/app-editors/mousepad/Manifest
@@ -1 +1,2 @@
DIST mousepad-0.5.10.tar.bz2 959696 BLAKE2B bd21145f23f1e92d67489a3ffcdca0afd977aa639706dece5aefd2f5417d2b2122accc1a5c727ec13a4c2f311ec479612953006d78b5509e836f360566d0d320 SHA512 144e72abce8e5fb66a345fb59efe48f136dd9cf9cdcd72496dcee05b08781bdbba036f4ab5af04dbccd38dc52a8e8dd67b5b7434867881a1114de692a012b076
+DIST mousepad-0.6.0.tar.bz2 969433 BLAKE2B 690046e80f5cc74d928a8ea4d1ebcb513cf56dcaa3b295d5da528cbd139c36bc464a63a1c72acb833bcbb6f92c56b7f50f8222a3e2422d12b1f08188c12d75e0 SHA512 dad3488c973d767759a8b9752f83cc45d339064d34c19ee51f576af13f8db441f7234982c09e85f4032d553ee8df4f50ce8e0aa66c921a60ddb5c262a1c93702
diff --git a/app-editors/mousepad/mousepad-0.6.0.ebuild b/app-editors/mousepad/mousepad-0.6.0.ebuild
new file mode 100644
index 000000000000..7867506e677b
--- /dev/null
+++ b/app-editors/mousepad/mousepad-0.6.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome2-utils xdg-utils
+
+DESCRIPTION="GTK+-based editor for the Xfce Desktop Environment"
+HOMEPAGE="
+ https://docs.xfce.org/apps/mousepad/start
+ https://gitlab.xfce.org/apps/mousepad/
+"
+SRC_URI="https://archive.xfce.org/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-libs/glib-2.56.2
+ >=x11-libs/gtk+-3.22:3
+ >=x11-libs/gtksourceview-4.0.0:4
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ dev-lang/perl
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local myconf=(
+ --enable-gtksourceview4
+ )
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}