summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ml/atd/atd-1.12.0.ebuild14
1 files changed, 9 insertions, 5 deletions
diff --git a/dev-ml/atd/atd-1.12.0.ebuild b/dev-ml/atd/atd-1.12.0.ebuild
index da91321baad5..5095732e9dd9 100644
--- a/dev-ml/atd/atd-1.12.0.ebuild
+++ b/dev-ml/atd/atd-1.12.0.ebuild
@@ -12,22 +12,27 @@ SRC_URI="https://github.com/mjambon/atd/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="~amd64"
-IUSE="+ocamlopt"
+IUSE="+ocamlopt test"
DEPEND="
dev-lang/ocaml:=[ocamlopt?]
dev-ml/easy-format:=[ocamlopt?]
dev-ml/menhir:=[ocamlopt?]
- dev-ml/biniou:=
- dev-ml/yojson:=
- !dev-ml/atdgen
"
RDEPEND="${DEPEND}"
DEPEND="${DEPEND}
dev-ml/jbuilder
dev-ml/opam
+ test? (
+ dev-ml/biniou
+ dev-ml/yojson
+ )
"
+src_compile() {
+ jbuilder build -p atd || die
+}
+
oinstall() {
opam-installer -i \
--prefix="${ED}/usr" \
@@ -38,5 +43,4 @@ oinstall() {
src_install() {
oinstall atd
- oinstall atdgen
}