summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-news/rssguard/Manifest1
-rw-r--r--net-news/rssguard/files/rssguard-3.5.9-qt-5.14.patch10
-rw-r--r--net-news/rssguard/rssguard-3.5.9.ebuild44
3 files changed, 55 insertions, 0 deletions
diff --git a/net-news/rssguard/Manifest b/net-news/rssguard/Manifest
index 403ac140ce57..b4046486040a 100644
--- a/net-news/rssguard/Manifest
+++ b/net-news/rssguard/Manifest
@@ -1 +1,2 @@
DIST rssguard-3.5.5.tar.gz 6446094 BLAKE2B 81a862f25f2c3029d4453faf03ddcfac1cd420a430acafff75bf15132d080b726910da82d1b7422f383eaec8b40a3956d7ad91d9368d9bd68fabcb9940dc3ad2 SHA512 4e6512c0d58c678145f63a2a42c43abfe4a6ceb8c9d395aba52228ca3afdaaf3dafdd79ab846dada16963f1be5dd22afb877910acc1425aea037d6fa1fc08996
+DIST rssguard-3.5.9.tar.gz 5775322 BLAKE2B f7d91e87b2a55d780bc1eae4f7e55b8059c049d21998f4c2554a84ca1d7b283e3145a556eef77e784d88ae2ad9f016d7b486a12141dceeada69dd1240205de23 SHA512 3a7223767185bf37bef316291b88d60bb2906fdbd0b045aa07c2ca4be19aadaeaa0b8c923f22aaa3483c7db783386744ad1411ad1ab214a8a71ef260948707b9
diff --git a/net-news/rssguard/files/rssguard-3.5.9-qt-5.14.patch b/net-news/rssguard/files/rssguard-3.5.9-qt-5.14.patch
new file mode 100644
index 000000000000..c1d9a8ccb5fe
--- /dev/null
+++ b/net-news/rssguard/files/rssguard-3.5.9-qt-5.14.patch
@@ -0,0 +1,10 @@
+--- a/src/gui/messagepreviewer.cpp 2019-06-04 13:16:48.000000000 +0200
++++ b/src/gui/messagepreviewer.cpp 2020-01-05 17:26:13.405430006 +0100
+@@ -9,6 +9,7 @@
+ #include "network-web/webfactory.h"
+ #include "services/abstract/serviceroot.h"
+
++#include <QKeyEvent>
+ #include <QScrollBar>
+ #include <QToolBar>
+ #include <QToolTip>
diff --git a/net-news/rssguard/rssguard-3.5.9.ebuild b/net-news/rssguard/rssguard-3.5.9.ebuild
new file mode 100644
index 000000000000..d6e9e59d36bc
--- /dev/null
+++ b/net-news/rssguard/rssguard-3.5.9.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic qmake-utils
+
+DESCRIPTION="Tiny RSS and Atom feed reader"
+HOMEPAGE="https://github.com/martinrotter/rssguard"
+SRC_URI="https://github.com/martinrotter/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="debug webengine"
+
+BDEPEND="dev-qt/linguist-tools:5"
+DEPEND="
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5[ssl]
+ dev-qt/qtsql:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ webengine? ( dev-qt/qtwebengine:5[widgets] )
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-qt-5.14.patch" )
+
+src_configure() {
+ # CONFIG+=ltcg is needed because of https://github.com/martinrotter/rssguard/issues/156
+ eqmake5 \
+ CONFIG+=$(usex debug debug release) \
+ $(is-flagq -flto* && echo "CONFIG+=ltcg") \
+ USE_WEBENGINE=$(usex webengine) \
+ PREFIX="${EPREFIX}"/usr \
+ INSTALL_ROOT=.
+}
+
+src_install() {
+ emake install INSTALL_ROOT="${D}"
+}