summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/healpy/Manifest1
-rw-r--r--dev-python/healpy/healpy-1.10.2.ebuild38
-rw-r--r--dev-python/healpy/healpy-1.10.3.ebuild2
3 files changed, 1 insertions, 40 deletions
diff --git a/dev-python/healpy/Manifest b/dev-python/healpy/Manifest
index 4cf3cc8c9d3c..f2f5ebae3302 100644
--- a/dev-python/healpy/Manifest
+++ b/dev-python/healpy/Manifest
@@ -1,2 +1 @@
-DIST healpy-1.10.2.tar.gz 4018889 SHA256 210fe8a1d3797e6ebb99125054d35d624229602179b119fc3b73586056307e4d SHA512 658dac9f9c3dfa8c6f4050138c81fc3f0c3b813ace797a531ea6fc7785d8a2e59ac07f8873a32682f06fde7097710cb91a8181f90bad82acdb04a20191d0601f WHIRLPOOL 216c336652866e3196cf86e073d29a87168f54b891d6b8382227fb49c961e9a28f8d64b3be980d37a006af989d0aa26c8b66deecd07973c8fcdb3f2b94647b6c
DIST healpy-1.10.3.tar.gz 4018897 SHA256 43bdccb0081b3b5a72a9c1f523c367bc2cba91f989a60047d8043685a3beb81b SHA512 c5862fceb597ffbc5c53204479fa9dba19287e3c08744e25edef3eaecfa726e61e8558d50d73e2bf4d19b7d0adc0ac928a38c4808fc92fe855f5eae101e18baa WHIRLPOOL f3d883f8de8c35573d865ab444818b5b3e3cbeac4176961cd8db39931a09b0d52a7f2fe7c6f3862823d32cd2ec2a569a17f6dc9e1da8510f35940f9ddbb7b66a
diff --git a/dev-python/healpy/healpy-1.10.2.ebuild b/dev-python/healpy/healpy-1.10.2.ebuild
deleted file mode 100644
index 03decf3f3399..000000000000
--- a/dev-python/healpy/healpy-1.10.2.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python wrapper for healpix"
-HOMEPAGE="https://github.com/healpy"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-RDEPEND="
- dev-python/astropy[${PYTHON_USEDEP}]
- dev-python/matplotlib[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- sci-astronomy/healpix:=[cxx]
- sci-libs/cfitsio:="
-DEPEND="${RDEPEND}
- dev-python/astropy-helpers[${PYTHON_USEDEP}]
- dev-python/cython[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- virtual/pkgconfig
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-
-DOCS=( README.rst CHANGELOG.rst CITATION )
-
-python_test() {
- echo "backend: Agg" > matplotlibrc || die
- MPLCONFIGDIR=. esetup.py test || die
- rm matplotlibrc || die
-}
diff --git a/dev-python/healpy/healpy-1.10.3.ebuild b/dev-python/healpy/healpy-1.10.3.ebuild
index 0d5b20cd7c73..f84e392eec9a 100644
--- a/dev-python/healpy/healpy-1.10.3.ebuild
+++ b/dev-python/healpy/healpy-1.10.3.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{4,5} )
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
inherit distutils-r1