summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/kafka-python/kafka-python-1.4.7.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-python/kafka-python/kafka-python-1.4.7.ebuild b/dev-python/kafka-python/kafka-python-1.4.7.ebuild
index d821f6d6524b..36adc8405d2e 100644
--- a/dev-python/kafka-python/kafka-python-1.4.7.ebuild
+++ b/dev-python/kafka-python/kafka-python-1.4.7.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
+PYTHON_COMPAT=( python3_{7..9} )
inherit distutils-r1
@@ -17,9 +17,9 @@ IUSE="snappy test"
RESTRICT="!test? ( test )"
RDEPEND="snappy? ( dev-python/snappy[${PYTHON_USEDEP}] )"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
+BDEPEND="
test? (
+ ${RDEPEND}
dev-python/mock[${PYTHON_USEDEP}]
dev-python/unittest2[${PYTHON_USEDEP}]
)"