summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-i18n/fcitx-cloudpinyin/Manifest1
-rw-r--r--app-i18n/fcitx-cloudpinyin/fcitx-cloudpinyin-0.3.6.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/app-i18n/fcitx-cloudpinyin/Manifest b/app-i18n/fcitx-cloudpinyin/Manifest
index 980d06d81892..8fdf783e1660 100644
--- a/app-i18n/fcitx-cloudpinyin/Manifest
+++ b/app-i18n/fcitx-cloudpinyin/Manifest
@@ -1 +1,2 @@
DIST fcitx-cloudpinyin-0.3.5.tar.xz 22424 BLAKE2B 9f44bf3a16681d994a8f202c7b9ba5bcb14a77c70e6e854626df675f647582632b6b4c110cf315fe376a6dd876607fe815d57d07361e219ddc11222ad1a95d6c SHA512 b56cde4955fab02d204cfe937b46aeb5b6adf9e4eb4fead6e7b8e0b5cd1ebce06a0de3f9d477a1cb58eb077655f17975b7e13951074d1766b283b86eeb5b276e
+DIST fcitx-cloudpinyin-0.3.6.tar.xz 22596 BLAKE2B e53f64dc999eb1ffb1d3c37b6ed75272da9a76d196df681b71876281ded778f83c73eef2f9100233f580a389e36bfc8681cd7be5e23ce4d9c27c26384062cf9a SHA512 d3a05fc48659db64a0a827c9b75cfb8b33f7cdb48bd936a2ba33f49469e29558a7da0f58cb7e6929b1265d451d23b0a37d87b7b69752599656c94049077d9914
diff --git a/app-i18n/fcitx-cloudpinyin/fcitx-cloudpinyin-0.3.6.ebuild b/app-i18n/fcitx-cloudpinyin/fcitx-cloudpinyin-0.3.6.ebuild
new file mode 100644
index 000000000000..8991ceab3f88
--- /dev/null
+++ b/app-i18n/fcitx-cloudpinyin/fcitx-cloudpinyin-0.3.6.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit cmake-utils
+
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/fcitx/fcitx-cloudpinyin"
+fi
+
+DESCRIPTION="Internet look-up support for Chinese Pinyin input methods for Fcitx"
+HOMEPAGE="https://fcitx-im.org/ https://github.com/fcitx/fcitx-cloudpinyin"
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://download.fcitx-im.org/${PN}/${P}.tar.xz"
+fi
+
+LICENSE="GPL-2+"
+SLOT="4"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND=">=app-i18n/fcitx-4.2.9:4
+ net-misc/curl:=
+ virtual/libiconv
+ virtual/libintl"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=()