summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-apps/smartmontools/smartmontools-9999.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/sys-apps/smartmontools/smartmontools-9999.ebuild b/sys-apps/smartmontools/smartmontools-9999.ebuild
index 499584db4c39..4b26ca97c630 100644
--- a/sys-apps/smartmontools/smartmontools-9999.ebuild
+++ b/sys-apps/smartmontools/smartmontools-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI=6
inherit autotools flag-o-matic systemd
if [[ ${PV} == "9999" ]] ; then
@@ -35,6 +35,7 @@ RDEPEND="${DEPEND}
daemon? ( virtual/mailx )
selinux? ( sec-policy/selinux-smartmon )
update_drivedb? (
+ app-crypt/gnupg
|| (
net-misc/curl
net-misc/wget
@@ -63,6 +64,7 @@ src_configure() {
$(use_with caps libcap-ng)
$(use_with selinux)
--with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
+ $(use_with update_drivedb gnupg)
$(use_with update_drivedb update-smart-drivedb)
)
econf "${myeconfargs[@]}"