summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-text/zathura-cb/zathura-cb-0.1.8.ebuild4
-rw-r--r--app-text/zathura-cb/zathura-cb-9999.ebuild4
2 files changed, 6 insertions, 2 deletions
diff --git a/app-text/zathura-cb/zathura-cb-0.1.8.ebuild b/app-text/zathura-cb/zathura-cb-0.1.8.ebuild
index 48ce63a869f5..98bbcc88ced1 100644
--- a/app-text/zathura-cb/zathura-cb-0.1.8.ebuild
+++ b/app-text/zathura-cb/zathura-cb-0.1.8.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit meson xdg-utils
+inherit meson xdg-utils optfeature
if [[ ${PV} == *9999 ]]; then
inherit git-r3
@@ -31,6 +31,8 @@ BDEPEND="virtual/pkgconfig"
pkg_postinst() {
xdg_desktop_database_update
+
+ optfeature "jpeg support" x11-libs/gdk-pixbuf:=[jpeg]
}
pkg_postrm() {
diff --git a/app-text/zathura-cb/zathura-cb-9999.ebuild b/app-text/zathura-cb/zathura-cb-9999.ebuild
index 58014fc992ed..2218f9a4ff84 100644
--- a/app-text/zathura-cb/zathura-cb-9999.ebuild
+++ b/app-text/zathura-cb/zathura-cb-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit meson xdg-utils
+inherit meson xdg-utils optfeature
if [[ ${PV} == *9999 ]]; then
inherit git-r3
@@ -31,6 +31,8 @@ BDEPEND="virtual/pkgconfig"
pkg_postinst() {
xdg_desktop_database_update
+
+ optfeature "jpeg support" x11-libs/gdk-pixbuf:=[jpeg]
}
pkg_postrm() {