summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/oslo-context/Manifest1
-rw-r--r--dev-python/oslo-context/oslo-context-2.21.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/oslo-context/Manifest b/dev-python/oslo-context/Manifest
index f723f91c4be8..ce3c2b4f4cd4 100644
--- a/dev-python/oslo-context/Manifest
+++ b/dev-python/oslo-context/Manifest
@@ -1 +1,2 @@
DIST oslo.context-2.20.0.tar.gz 28203 BLAKE2B cbb3cb6f30b1b16011caa6fdec36c19aae571125b88f642bfc52c5a8a63a2b17eb308628d9a5f19b8a0c3bd28fb0db54e5485abd10c90c9495de05263ac25709 SHA512 ce7bd92c7e22e02e91bdc86e9b697f746233a41081b4f3ebb9fe30fec8000c69f732f55de0d333b349b8e01e638ddc835fd3cf0d8f7a11aa3454466a1e87ad08
+DIST oslo.context-2.21.0.tar.gz 27605 BLAKE2B fa2be8819c3b5c46e12eacae12c665e8168c4d8ac88fe7e8b8c3454093ea14d1a5980d1ecc377eb7294d913e117cf5188571be3bf678f270712e09c5230f2f7e SHA512 af25aebd306d0a3d60032778e6e3ca10b976e758c10e5d02302ebfef6a6183c8f9a102e9b4c2c8400914d71976dff284654bbcec63c15192dcfd2605928596eb
diff --git a/dev-python/oslo-context/oslo-context-2.21.0.ebuild b/dev-python/oslo-context/oslo-context-2.21.0.ebuild
new file mode 100644
index 000000000000..4d0db0d234d3
--- /dev/null
+++ b/dev-python/oslo-context/oslo-context-2.21.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Helpers to maintain useful information about a request context"
+HOMEPAGE="https://pypi.org/project/oslo.context/"
+SRC_URI="mirror://pypi/${PN:0:1}/oslo.context/oslo.context-${PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+ test? (
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
+ !~dev-python/coverage-4.4[${PYTHON_USEDEP}]
+ >=dev-python/bandit-1.1.0[${PYTHON_USEDEP}]
+ )"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/debtcollector-1.2.0[${PYTHON_USEDEP}]
+"
+
+S="${WORKDIR}/oslo.context-${PV}"
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}
+
+# This time half the doc files are missing; Do you want them?
+python_test() {
+ nosetests tests/ || die "test failed under ${EPYTHON}"
+}