summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-haskell/wreq/Manifest1
-rw-r--r--dev-haskell/wreq/wreq-0.5.3.2.ebuild76
2 files changed, 0 insertions, 77 deletions
diff --git a/dev-haskell/wreq/Manifest b/dev-haskell/wreq/Manifest
index dcd50787f9b9..0f5293301a69 100644
--- a/dev-haskell/wreq/Manifest
+++ b/dev-haskell/wreq/Manifest
@@ -1,2 +1 @@
-DIST wreq-0.5.3.2.tar.gz 57521 BLAKE2B 2265e7f8abe371371d079f735d61917c0efa5b78e2d3e8965e3b720a94e89b3a7ae05824f54d6fe765c643ed81f506b12694355b0bf1d7b4c2e9198d08c2317c SHA512 5a2c62b973758cb8ce2bf20504e328090896fa25e7ee1f77b472d7cf5156e08b6d85bf4341ff45e44db1724070fcf3c0f21037fa0a79211a1767024328f7c779
DIST wreq-0.5.3.3.tar.gz 57561 BLAKE2B 31849f85b612d4f15c9a50f7e180850b7270c854bc86fc447880ca5740fb4acbd2acbddd65ec2b279180615616b0aac5332d0d352d412ee5665e8e2824fbcde3 SHA512 f074790cf3370d9356efbf5aeabb7421d59299471e02d93010453bb6f4e8daee517fcdf6891245272a9b08a35bc7b1b2233b75825ec377f6403c99cf91041f2e
diff --git a/dev-haskell/wreq/wreq-0.5.3.2.ebuild b/dev-haskell/wreq/wreq-0.5.3.2.ebuild
deleted file mode 100644
index 62ccd4251442..000000000000
--- a/dev-haskell/wreq/wreq-0.5.3.2.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-# ebuild generated by hackport 0.6.2
-#hackport: flags: -developer,+doctest
-
-CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
-inherit haskell-cabal
-
-DESCRIPTION="An easy-to-use HTTP client library"
-HOMEPAGE="http://www.serpentine.com/wreq"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE="aws httpbin"
-
-RESTRICT=test # needs network
-
-RDEPEND=">=dev-haskell/aeson-1.0.0.0:=[profile?]
- >=dev-haskell/attoparsec-0.11.1.0:=[profile?]
- >=dev-haskell/authenticate-oauth-1.5:=[profile?]
- dev-haskell/base16-bytestring:=[profile?]
- dev-haskell/case-insensitive:=[profile?]
- dev-haskell/cryptonite:=[profile?]
- >=dev-haskell/exceptions-0.5:=[profile?]
- dev-haskell/hashable:=[profile?]
- >=dev-haskell/http-client-0.6:=[profile?]
- >=dev-haskell/http-client-tls-0.3.3:=[profile?]
- >=dev-haskell/http-types-0.8:=[profile?]
- >=dev-haskell/lens-4.5:=[profile?]
- dev-haskell/lens-aeson:=[profile?]
- dev-haskell/memory:=[profile?]
- dev-haskell/mime-types:=[profile?]
- >=dev-haskell/psqueues-0.2:=[profile?]
- dev-haskell/text:=[profile?]
- dev-haskell/time-locale-compat:=[profile?]
- dev-haskell/unordered-containers:=[profile?]
- >=dev-lang/ghc-7.10.1:=
- httpbin? ( >=dev-haskell/aeson-pretty-0.8.0:=[profile?]
- dev-haskell/base64-bytestring:=[profile?]
- >=dev-haskell/snap-core-1.0.0.0:=[profile?]
- >=dev-haskell/snap-server-0.9.4.4:=[profile?]
- dev-haskell/unix-compat:=[profile?]
- dev-haskell/uuid:=[profile?] )
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.22.2.0
- >=dev-haskell/cabal-doctest-1.0.2 <dev-haskell/cabal-doctest-1.1
- test? ( dev-haskell/doctest
- dev-haskell/hunit
- dev-haskell/network-info
- >=dev-haskell/quickcheck-2.7
- dev-haskell/temporary
- dev-haskell/test-framework
- dev-haskell/test-framework-hunit
- dev-haskell/test-framework-quickcheck2
- dev-haskell/vector
- !httpbin? ( >=dev-haskell/aeson-pretty-0.8.0
- dev-haskell/base64-bytestring
- >=dev-haskell/snap-core-1.0.0.0
- >=dev-haskell/snap-server-0.9.4.4
- dev-haskell/unix-compat
- dev-haskell/uuid ) )
-"
-
-src_configure() {
- haskell-cabal_src_configure \
- $(cabal_flag aws aws) \
- --flag=-developer \
- --flag=doctest \
- $(cabal_flag httpbin httpbin)
-}