summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/python-scsi/Manifest1
-rw-r--r--dev-python/python-scsi/metadata.xml11
-rw-r--r--dev-python/python-scsi/python-scsi-0_pre160211.ebuild26
-rw-r--r--dev-python/python-scsi/python-scsi-9999.ebuild19
4 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/python-scsi/Manifest b/dev-python/python-scsi/Manifest
new file mode 100644
index 000000000000..bc47ea98fe7e
--- /dev/null
+++ b/dev-python/python-scsi/Manifest
@@ -0,0 +1 @@
+DIST python-scsi-0_pre160211.zip 126606 SHA256 a86f6cb42fbf45b186fdfbdb697b001dfabf773e698b30dae46815b1aa4f90ad SHA512 43218dfe91eba8f79c0cc7b48e5d7ba3026aac3d0c70dc2d8865905ef70bc479c6a32c46104b3284a00b5832d8893daf4285aac84fd43f1a1ba80affeaf5e258 WHIRLPOOL d44417d7461db3c779805f15311bd51ed0af154237516433ef17a5a23c72c502d6cb09ecf36de913f735a9bc0ce6c4608395167e1e5e850babd3e65dd4ca6c3a
diff --git a/dev-python/python-scsi/metadata.xml b/dev-python/python-scsi/metadata.xml
new file mode 100644
index 000000000000..0f3589e95f63
--- /dev/null
+++ b/dev-python/python-scsi/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>flameeyes@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/python-scsi/python-scsi-0_pre160211.ebuild b/dev-python/python-scsi/python-scsi-0_pre160211.ebuild
new file mode 100644
index 000000000000..5754950f1fbd
--- /dev/null
+++ b/dev-python/python-scsi/python-scsi-0_pre160211.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 eutils
+
+HASH="957e5538d8d441fb792db6fbbdc0a5e8d57d9c7d"
+
+DESCRIPTION="Access to SG_IO scsi devices"
+HOMEPAGE="https://github.com/rosjat/python-scsi/"
+SRC_URI="https://github.com/rosjat/python-scsi/archive/${HASH}.zip -> ${P}.zip"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+S="${WORKDIR}"/${PN}-${HASH}
+
+pkg_postinst() {
+ optfeature "iSCSI support" dev-python/libiscsi-python
+}
diff --git a/dev-python/python-scsi/python-scsi-9999.ebuild b/dev-python/python-scsi/python-scsi-9999.ebuild
new file mode 100644
index 000000000000..6a6e10d519ed
--- /dev/null
+++ b/dev-python/python-scsi/python-scsi-9999.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 git-r3
+
+DESCRIPTION="Access to SG_IO scsi devices"
+HOMEPAGE="https://github.com/rosjat/python-scsi/"
+SRC_URI=""
+EGIT_REPO_URI="https://github.com/rosjat/python-scsi.git"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""