summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-cluster/charliecloud/Manifest1
-rw-r--r--sys-cluster/charliecloud/charliecloud-0.2.4.ebuild67
-rw-r--r--sys-cluster/charliecloud/charliecloud-9999.ebuild36
-rw-r--r--sys-cluster/charliecloud/metadata.xml7
4 files changed, 89 insertions, 22 deletions
diff --git a/sys-cluster/charliecloud/Manifest b/sys-cluster/charliecloud/Manifest
index efddd318d97d..8a9996040096 100644
--- a/sys-cluster/charliecloud/Manifest
+++ b/sys-cluster/charliecloud/Manifest
@@ -1 +1,2 @@
DIST charliecloud-0.2.3_pre20171121.tar.gz 82636 BLAKE2B 6eb8465da39dc628d8cf65b475263b6ff12757fec00ede16025c126bc861ab07969fb8a815fbdfa48424911905d59e1290f6281a8d804d069cf940b7a0e66b47 SHA512 1828651d18cd8246e0d462fa966052be21a18f0a7a6bdb76040740dd97b271723c317ed764296cf2d0e554cec527612a02e733ec7bf3e6f4ac73139fed968c83
+DIST charliecloud-0.2.4.tar.gz 178589 BLAKE2B 45330f67e4b116150219a2753f341248878e8fa540583a97c5cd55e42498825e749c5ca9133580c180438898e25dd22bbcec37c31c31258ccf1fa0ffb5814375 SHA512 456b45d071a18562d914e70b141de55950fcf4a5e2aa882b85bdd8c4abab3a62ab1e413c0524a31be2e278328aab67a898f319bd640e9d9a84163efe24e5a872
diff --git a/sys-cluster/charliecloud/charliecloud-0.2.4.ebuild b/sys-cluster/charliecloud/charliecloud-0.2.4.ebuild
new file mode 100644
index 000000000000..f7d1882d07be
--- /dev/null
+++ b/sys-cluster/charliecloud/charliecloud-0.2.4.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# User namespaces don't play well with the sandbox.
+RESTRICT="test"
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/hpc/${PN}.git"
+ S="${WORKDIR}/${P}"
+else
+ SRC_URI="https://github.com/hpc/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+DESCRIPTION="Lightweight user-defined software stacks for high-performance computing"
+HOMEPAGE="https://hpc.github.io/charliecloud/"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+IUSE="doc examples +pv test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ pv? ( sys-apps/pv )
+ doc? ( dev-python/sphinx
+ dev-python/sphinx_rtd_theme
+ net-misc/rsync )
+ test? ( app-arch/pigz )"
+
+DOCS=(
+ README.rst
+)
+
+src_compile() {
+ emake
+ use doc && emake -C doc-src
+}
+
+src_install() {
+ emake install PREFIX="${EPREFIX}/usr" DESTDIR="${ED}"
+ if use doc; then
+ mv doc html || die
+ local HTML_DOCS=(html/.)
+ fi
+ if use examples; then
+ docompress -x "${EPREFIX}/usr/share/doc/${PF}/examples"
+ DOCS+=(examples)
+ fi
+ rm -rf "${ED}/usr/share/doc/charliecloud" || die
+ einstalldocs
+}
+
+src_test() {
+ cd "${S}/test" || die
+ export CH_TEST_TARDIR="${T}/tarballs"
+ export CH_TEST_IMGDIR="${T}/images"
+
+ # Do not run tests requiring root.
+ export CH_TEST_PERMDIRS="skip"
+ export CH_TEST_SKIP_DOCKER=yes
+ sed -i 's/CHTEST_HAVE_SUDO=yes/CHTEST_HAVE_SUDO=no/' "${S}/test/common.bash" || die
+
+ emake test-quick
+}
diff --git a/sys-cluster/charliecloud/charliecloud-9999.ebuild b/sys-cluster/charliecloud/charliecloud-9999.ebuild
index 31d3d0f93db0..f7d1882d07be 100644
--- a/sys-cluster/charliecloud/charliecloud-9999.ebuild
+++ b/sys-cluster/charliecloud/charliecloud-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
# User namespaces don't play well with the sandbox.
RESTRICT="test"
@@ -13,7 +13,6 @@ if [[ ${PV} == "9999" ]] ; then
else
SRC_URI="https://github.com/hpc/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
- S="${WORKDIR}/${P}"
fi
DESCRIPTION="Lightweight user-defined software stacks for high-performance computing"
@@ -21,44 +20,37 @@ HOMEPAGE="https://hpc.github.io/charliecloud/"
SLOT="0"
LICENSE="Apache-2.0"
-IUSE="doc examples suid test"
+IUSE="doc examples +pv test"
RDEPEND=""
DEPEND="${RDEPEND}
+ pv? ( sys-apps/pv )
doc? ( dev-python/sphinx
dev-python/sphinx_rtd_theme
net-misc/rsync )
test? ( app-arch/pigz )"
+DOCS=(
+ README.rst
+)
+
src_compile() {
- if use suid; then
- export SETUID=1
- fi
emake
- if use doc && ! use suid; then
- emake -C doc-src
- fi
+ use doc && emake -C doc-src
}
src_install() {
- if use suid; then
- export SETUID=1
- fi
emake install PREFIX="${EPREFIX}/usr" DESTDIR="${ED}"
- dodoc README.rst COPYRIGHT
- if use doc && ! use suid; then
- if ! use suid; then
- mv doc html || die
- dodoc -r html
- else
- ewarn "Building documentation with SUID not supported yet!"
- fi
+ if use doc; then
+ mv doc html || die
+ local HTML_DOCS=(html/.)
fi
if use examples; then
docompress -x "${EPREFIX}/usr/share/doc/${PF}/examples"
- dodoc -r examples
+ DOCS+=(examples)
fi
rm -rf "${ED}/usr/share/doc/charliecloud" || die
+ einstalldocs
}
src_test() {
diff --git a/sys-cluster/charliecloud/metadata.xml b/sys-cluster/charliecloud/metadata.xml
index 101def06620c..6db8cc60e6a4 100644
--- a/sys-cluster/charliecloud/metadata.xml
+++ b/sys-cluster/charliecloud/metadata.xml
@@ -5,6 +5,10 @@
<email>o.freyermuth@googlemail.com</email>
<name>Oliver Freyermuth</name>
</maintainer>
+ <maintainer type="person">
+ <email>junghans@gentoo.org</email>
+ <name>Christoph Junghans (proxy)</name>
+ </maintainer>
<maintainer type="project">
<email>proxy-maint@gentoo.org</email>
<name>Proxy Maintainers</name>
@@ -12,4 +16,7 @@
<upstream>
<remote-id type="github">hpc/charliecloud</remote-id>
</upstream>
+ <use>
+ <flag name='pv'>Use sys-apps/pv to enable progress bar functionality</flag>
+ </use>
</pkgmetadata>